English
Ask Your Question
2

How do I change my boot theme? [closed]

asked 2011-09-30 16:18:28 +0000

kirkb gravatar image

I understand there are many themes out there for the software called Plymouth, but I'm not clear on how to actually change the theme.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by zoltanh721
close date 2014-07-05 03:22:08.112403

4 answers

Sort by ยป oldest newest most voted
3

answered 2013-01-30 19:08:16 +0000

Robo gravatar image

Run these commands as root:

# plymouth-set-default-theme <plymouth theme>
# dracut --force

And then, restart your computer

edit flag offensive delete link more

Comments

This one worked for me, all others didn't work. Make sure install the theme (yum install plymouth-theme-xxx) before running these commands

florian ( 2014-02-13 05:29:53 +0000 )edit
7

answered 2011-09-30 20:57:52 +0000

The following command would show the available themes:

# plymouth-set-default-theme --list
charge
details
text

Install your favorite theme, I have installed solar for example:

yum install plymouth-theme-solar

Now list again

# plymouth-set-default-theme --list
charge
details
solar
text

Now to set a new theme, just do:

# sudo plymouth-set-default-theme solar

and

# sudo /usr/libexec/plymouth/plymouth-update-initrd

then

# reboot
edit flag offensive delete link more

Comments

Works, but you need to add/remove rhgb to grub kernel line.

hello ( 2014-08-10 01:52:49 +0000 )edit

You must rebuild your grub config as well or your changes will not be visible.

sudo grub2-mkconfig -o /boot/grub2/grub.cfg
shrewmouse ( 2015-10-08 13:05:43 +0000 )edit
2

answered 2014-02-12 02:26:37 +0000

binaryhat1 gravatar image

updated 2014-02-12 02:41:40 +0000

On Fedora 20 it is:

# sudo plymouth-set-default-theme <plymouth theme> -R

and reboot

edit flag offensive delete link more

Comments

Works nicely under Fedora 25.

c72578 ( 2016-12-09 10:12:34 +0000 )edit
0

answered 2014-02-05 06:41:19 +0000

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

http://www.tejasbarot.com/2009/01/19/enable-graphical-boot-with-plymouth/

you have to make a vga declaration in grub.conf

edit flag offensive delete link more

Comments

This solved my problem! Thank you!

lpse2000 ( 2015-09-06 05:18:00 +0000 )edit

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2011-09-30 16:18:28 +0000

Seen: 29,642 times

Last updated: Feb 12 '14