Ask Your Question
0

LibreOffice: Unable To Open Files By Double Click or Keyboard Button

asked 2017-03-09 20:32:31 -0500

linux.newbie gravatar image

Hi there, I just want to ask if there are others who are experiencing the same problem.

Whenever I try to open a file associated to LibreOffice (ods, odt, odp, and even xlsx or docx) using mouse's double click or my laptop's keyboard button, it always creates a new folder which contains the metadata of the actual file that I am trying to open. It seems that it is extracting the file whenever I open it using the aforementioned methods. I checked the default application to use for each file and confirmed that LibreOffice is set as default. Problem started when I updated my system couple of days ago. I tried reverting to previous kernel version but the behaviour is still the same. I tried reverting my LibreOffice version to the default version, same issue.

Here are my system details:

OS: Korora 25 LibreOffice version: 5.2.6.2 Kernel: 4.9.13-200

Any suggestions or advice will be highly appreciated.

Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-03-09 23:02:18 -0500

linux.newbie gravatar image

Found a workaround. Not sure if this is an issue with Nautilus. On the File Manager's Preferences, under Behaviour Tab, there is a setting "Extract on Open", uncheck it.

Will wait for next update probably for the fix.

edit flag offensive delete link more

Comments

I think your workaround is the answer, at least for now. In GNOME 3.22, Nautilus includes built-in support for archives. Its default behavior on double-click is to extract the files into a folder. OpenDocument files are ZIP archives, so what you're seeing is a feature, not a bug.

I think it's an incomplete feature. There needs to be a way to tell Nautilus not to treat certain "archives" as archives.

tonygreene gravatar imagetonygreene ( 2017-03-13 23:08:52 -0500 )edit

So, how do I find the File Manager's Preferences to get to the Behavior Tab on Korora 25? I'm using Gnome without Wayland because so many things I use still don't work with Wayland.

ddorris gravatar imageddorris ( 2017-03-22 15:57:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-03-09 20:32:31 -0500

Seen: 357 times

Last updated: Mar 09 '17