English
Ask Your Question
0

Reduced Graphics Performance Fedora25 (intel/nvidia)

asked 2017-03-20 23:53:53 +0000

bub gravatar image

updated 2017-03-21 14:52:18 +0000

This is my bench mark for testing graphics performance: "export vblank_mode=0; glxgears".

I had upgraded to Fedora25 and was getting a solid 12,000 FPS. Now I am getting 1,000 FPS.

So I know that stock Fedora can do it, but I've lost the proper configuration and can't figure out the issue.

This is hybrid graphics hardware. An Intel Haswell controller (HD 4600) which feeds 3D rendering to a back-end nVidia chip (GK107GLM [Quadro K1100M]).

Yes, there are two chips, but the second is not directly addressable as a display device. There is no BIOS option for manipulating integrated versus discrete garphics. All processing goes through the Intel chip which off loads to the nVidia chip. Thus solutions that recommend bumblebee, optimus, or prime do not apply here. There are no nVidia proprietary drivers loaded. Using gdm-x-session

I found some old notes which indicate that the nvidia chip should be listed as a provider from xrandr, with Source Offload and the nouveau driver. However, the current output from xrandr does not list the second chip, only the Intel chip.

Some potentially helpful output below.

Any ideas on where to look for a solution? Thanks in advance!

# inxi -Fzx

System:    Host: xyzzy Kernel: 4.9.14-200.fc25.x86_64 x86_64 (64 bit gcc: 6.3.1)
           Desktop: Cinnamon 3.2.8 (Gtk 3.22.10) Distro: Fedora release 25 (Twenty Five)
CPU:       Quad core Intel Core i7-4712HQ
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GK107GLM [Quadro K1100M] bus-ID: 02:00.0
           Display Server: X.org 1.19.1 drivers: nouveau,intel (unloaded: modesetting,fbdev,vesa)
# xrandr --listproviders 
Providers: number : 1
Provider 0: id: 0x48 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 5 associated providers: 0 name:Intel
# lshw -class display
  *-display UNCLAIMED
       description: 3D controller
       product: GK107GLM [Quadro K1100M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:eb000000-ebffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:ec000000-ec07ffff
  *-display
       description: VGA compatible controller
       product: 4th Gen Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 06
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:30 memory:ec400000-ec7fffff memory:80000000-8fffffff ioport:f000(size=64) memory:c0000-dffff
edit retag flag offensive close merge delete

Comments

I haven't heard of that setup. So it's not nvidia Optimus/hybrid but it "feeds 3D rendering to a back-end nvidia chip"? Maybe that's where you need to check then; if it's still passing off 3D rendering to dedicated GPU or if that's done by the Integrated GPU now.

ILMostro ( 2017-03-21 03:19:33 +0000 )edit

Thanks, ILMostro. My description may not be technically accurate. Guess it is "optimus hardware", however the second (nvidia) GPU is not directly addressable as a display device. The performance was great (12,000 FPS) without any bumblebee/optimus/prime software package loaded.

I'm not sure why "xrandr --listproviders" does not show the nvidia GPU. Perhaps that is a clue?

bub ( 2017-03-21 04:16:24 +0000 )edit

Submitted a bugzilla report:

https://bugzilla.redhat.com/show_bug.cgi?id=1434531

bub ( 2017-03-21 23:17:09 +0000 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2017-03-22 18:30:06 +0000

bub gravatar image
# ls -1 /lib/modprobe.d
dist-alsa.conf
dist-blacklist.conf
nvidia-installer-disable-nouveau.conf
openfwwf.conf

# cat /lib/modprobe.d/nvidia-installer-disable-nouveau.conf 
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0

# rm /lib/modprobe.d/nvidia-installer-disable-nouveau.conf 

# shutdown -r now

...

# xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x88 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 5 associated providers: 1 name:Intel
Provider 1: id: 0x5f cap: 0x5, Source Output, Source Offload crtcs: 0 outputs: 0 associated providers: 1 name:nouveau
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-03-20 23:53:53 +0000

Seen: 146 times

Last updated: Mar 22