Ask Your Question
0

Disable ALPS DualPoint Stick in Wayland

asked 2017-03-24 04:42:06 -0500

I have a Toshiba Portege that suffers from a wandering mouse pointer. This is caused by a dodgy DualPoint/Trackpoint stick. Previously when running xorg I could disable this using xinput disable [ID]. How can I do this with Wayland?

Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-05-29 12:06:37 -0500

PaulS gravatar image

First confirm that the DualPoint Stick is present: To get a list of input devices type the following.

# sudo libinput list-devices

If the device is present, then create a udev rule in /etc/udev/rules.d by pasting the following in a text file with a name like 90-disable-pointing-stick.rules. Note that wildcards are allowed in ATTRS(name). Also note that the rule is case sensitive. Then reboot. The ALPS DualPoint Stick should now be disabled

# ALPS DualPoint Stick: Ignore as input device
ATTRS{name}=="*DualPoint Stick", ENV{ID_INPUT}="", ENV{ID_INPUT_MOUSE}="", ENV{ID_INPUT_POINTINGSTICK}=""
LABEL="input_end"
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-03-24 04:42:06 -0500

Seen: 122 times

Last updated: Mar 24 '17