Ask Your Question

nvidia - issues

asked 2017-04-14 22:11:51 +0000

darlac gravatar image

updated 2017-04-17 18:06:40 +0000

hhlp gravatar image

17/4 UPDATE Looking at my xorg.log file I noticed something that might be related to my nvidia issues: apparently my settings are not being seen - how can I fix that?

[     7.594] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 17 13:51:50 2017
[     7.596] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     7.596] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     7.607] (==) No Layout section.  Using the first Screen section.
[     7.607] (==) No screen section available. Using defaults.
[     7.607] (**) |-->Screen "Default Screen Section" (0)
[     7.607] (**) |   |-->Monitor "<default monitor>"
[     7.607] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[     7.607] (==) Automatically adding devices
[     7.607] (==) Automatically enabling devices
[     7.607] (==) Automatically adding GPU devices
[     7.607] (==) Automatically binding GPU devices
[     7.607] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     7.607] (==) FontPath set to:

Hi all, I am new to fedora - I bought a new pc and wanted to move fwd (mint in my last pc); I have installed fedora 25 - cinnamon; my pc (MSI Leopard pro) has i7 and GeForce gtx 1060; I tried all different approaches for installing the driver (with the nouveau driver I had issues with the hdmi external monitors). Anyway, now I have installed the nvidia driver package (as described in negativo17 site - http://negativo17.org/nvidia-driver/ ) my 2 problems:

  1. I cannot log in directly to a graphical interface; I have to use the multi-user target, and then 'startx'; I would like to be able to log in directly

  2. when on battery, the battery drains like crazy; I get ~ 1 hr of usage (with dimmed screen etc) [for comparison with the nouveau only I could get ~ 2.5 hrs)

any help is appreciated~

PS output of the lspci | grep -e VGA
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev a1)
edit retag flag offensive close merge delete


Have you tried Bumblebee? It tends to work better for laptops that have both Intel and Nvidia cards. Other wise you might have to see if you can disable the intel graphics in your UEFI/BIOS. I suspect the reason for the shorter battery life is that its running the discrete card the whole time where as with Nouveau it was probably just using the integrated card unless you ran something with DRI_PRIME=1

Entropy803 ( 2017-04-17 13:08:49 +0000 )edit

Thanks Entropy803, I tried Bumblebee, but with no luck - I might try again. I will try to disable the integrated one in bios and see what is happening (in nvidia-settings the active monitor appears as PRIME; not sure what this means)

darlac ( 2017-04-17 13:42:11 +0000 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2017-04-17 21:51:34 +0000

darlac gravatar image

updated 2017-04-18 22:22:21 +0000

UPDATE[4/18] actually all works fine only with gdm and Gnome3; lightDM and cinnamon (which I was using for the past few days) still has problems (the intel on board card works fine, but not the nvidia one).

Ok, after looking around and reading about the issue I tried the Bumblebee driver; this time I followed the fedora wiki on bumblebee link text and also read the details on the antergos wiki link text small details on the latter (never run the xconfig file, and changing the menu entry) Will have to test with exernal monitor now

edit flag offensive delete link more

answered 2017-04-15 02:00:35 +0000

steveebey73742 gravatar image

login as root

systemctl set-default graphical.target

as far as power drain, go to the nvidia-settings and set the powermizer to adaptive. if the fan control and powermizer do not show as available, go to terminal and sudo nvidia-xconfig --cool-bits=12 to allow the fan control and powermizer to be available to use. run sudo nvidia-settings and adjust them as you need to.

edit flag offensive delete link more


thanks steevebey when I set the default to graphical target (systemctl set-default graphical.target) the system boots to a black screen - I have to hard reboot, and then log in level 3 thanks for the nvidia tips (I have it in adaptive) - I will check the settings

darlac ( 2017-04-15 12:57:12 +0000 )edit

When at the black screen, can you Ctrl-Alt-F2 and login root? if so, dmesg or jounalctl -xe may yield the reason that the computer goes black. Might need to run the nvidia-xconfig to adjust the xserver config to a matching display. I run the patched 378.13 prprietary driver, if you search here on ask fedora, you can find the patch and links to the driver. I let dkms update kernel mods, and installed the 32 bit, so I can run steam also. I have the gtx 970 and this morning updated to kernel 4.10.9 with no issues.

steveebey73742 ( 2017-04-15 13:19:19 +0000 )edit

Yes I can login root; dmesg and journalctl -xe showed no obvious problems (at least to my inexperienced eyes) With the nvidia driver (from negativo17) I can log in the graphical interface (two steps described above); with the pathced driver - I cannot I also drive the nvidia-config; if an xorg.conf file is present, I cannot log in (graphical interface)

darlac ( 2017-04-17 13:40:33 +0000 )edit

Sounds like an issue with corrupted xconfig, from the auto start. when you log in manaully, after using startx, have you examined the xorg.conf to see which device the card is using. since you are dual video, you may need to force a device set, to give preference to nvidia. I will look into how to do that, and let you know.

steveebey73742 ( 2017-04-17 13:54:42 +0000 )edit

Hi there, actually there is no xorg.conf by default [if I add with nvidia-xconfig then I cannot log in, not even in terminal]; the information is stored in xorg.conf.d [from what I understand]

darlac ( 2017-04-17 17:14:55 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

1 follower


Asked: 2017-04-14 22:11:51 +0000

Seen: 241 times

Last updated: Apr 18 '17