Ask Your Question
0

Only mouse cursor visible after inactivity

asked 2017-04-16 17:07:28 -0500

xzise gravatar image

updated 2017-04-19 05:25:44 -0500

Since kernel version 4.10.6 I've the problem that when I try to log in after inactivity it only shows the mouse cursor on a black screen.

I can switch to other ttys (including the GUI login “tty1” (Ctrl+Alt+F1)), but everytime I switch to “tty2” I get the issue back. When I try to log in, it just switches to the second tty and the issue is still there. I tried testing whether I can get this issue when I lock the screen actively (and even leave it be for a few minutes) but it didn't cause the issue.

At the moment my workaround is to use it with an outdated kernel still installed (4.9.17) but every kernel since (4.10.6, 4.10.8, 4.10.9 and 4.10.10) show this error.

edit retag flag offensive close merge delete

Comments

I have the same problem with the 4.10.x kernels. My system that is having this problem has an older Nvidia card (GeForce GTX 560) using the nouveau driver, Are you using a Nvidia video card, too? I suspect a problem between the 4.10 kernel, the nouveau driver, and the video card, as dmesg shows a memory allocation error when I try to wake the screen.

anotherlinuxuser gravatar imageanotherlinuxuser ( 2017-04-22 00:42:11 -0500 )edit

I'm also using nouveau and a Nvidia video card. I'll try to check dmesg the next time it happens.

xzise gravatar imagexzise ( 2017-04-23 05:00:10 -0500 )edit

I have the same problem. Running a Dell notebook with an Intel integrated graphic card ...

EllePi gravatar imageEllePi ( 2017-05-08 01:11:09 -0500 )edit

The issue is still in place. Any news?

EllePi gravatar imageEllePi ( 2017-05-11 01:45:28 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2017-05-14 18:06:48 -0500

xzise gravatar image

Okay I couldn't really test it until recently and then the kernel 4.10.14 was released which actually fixed it for me.

edit flag offensive delete link more
0

answered 2017-05-15 04:42:52 -0500

genodeftest gravatar image

Have you tried pressing the Enter key, the Esc key, Ctrl+L or moving the mouse while clicking?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-04-16 17:07:28 -0500

Seen: 46 times

Last updated: May 15 '17