English
Ask Your Question
0

Turn displays off without suspend/hibernate.

asked 2017-04-17 11:58:08 +0000

artdvla gravatar image

Without suspending or hibernating (neither of which work on my laptop; quite frankly, i'm resigned at ever trying to get them to work), I need to be able to shut off my screens in order to save power and the displays' life.

Hitting Super + L locks the screen and they (Laptop + Externals) all turn black. However, the backlights remain lit. How can I get the displays to turnoff while the computer remains running (e.g., still allowing me to ssh in and maintaining everything in memory).

edit retag flag offensive close merge delete

4 answers

Sort by ┬╗ oldest newest most voted
0

answered 2017-04-17 18:37:59 +0000

Rabin gravatar image

With MATE desktop and under X I use xset for that, type:

xset dpms 3600 3600 3600

this will enable Display Power Management and will set the time out to 3600 sec (1 hour)

edit flag offensive delete link more

Comments

That did it. Very easy. Thank you.

artdvla ( 2017-04-18 15:32:04 +0000 )edit

This should happen automatically. You should file a bug against your desktop environment.

genodeftest ( 2017-04-20 20:23:07 +0000 )edit
0

answered 2017-04-19 15:06:57 +0000

sixpack13 gravatar image

cit: "Without suspending or hibernating (neither of which work on my laptop; quite frankly, i'm resigned at ever trying to get them to work) ..."

is your swap partition in your /etc/default/grub ? like this:

GRUB_CMDLINE_LINUX=" resume=/dev/sdXN rhgb quiet"

afterwards you need (only one):

sudo /sbin/grub2-mkconfig -o /boot/grub2/grub.cfg  
sudo /sbin/grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
edit flag offensive delete link more
0

answered 2017-04-17 15:36:07 +0000

genodeftest gravatar image
  1. Do you have updates installed? Has this issue started showing recently or has it been present for a longer time?

  2. You might want to look at https://01.org/blogs/rzhang/2015/best... for the suspend/hibernate issues

  3. Regarding the backlight issue, please have a look at https://wiki.archlinux.org/index.php/... and check whether the backlight is detected correctly at all (section "ACPI") and if yes, may be the last section is of help to you.

edit flag offensive delete link more
-1

answered 2017-04-17 12:50:37 +0000

lsatenstein gravatar image

For a black screen, I visit System-┬╗Power and set the timeout there to the miinmum, which is 1 minute. Screen blanks after 1 minute of no activity.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-04-17 11:58:08 +0000

Seen: 62 times

Last updated: Apr 19