Wired connection doesnot turn on

asked 2017-04-19 07:14:57 +0000

updated 2017-04-19 11:38:01 +0000

hhlp gravatar image

I am trying to connect to the internet through a LAN connection, but the network is shown to be off.I checked the cables and the connection. They are perfectly ok. So I wonder how to correct it. Here is an output from

$ ifconfig

`enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether 54:04:a6:2f:65:50  txqueuelen 1000  (Ethernet)
        RX packets 7323772  bytes 568448612 (542.1 MiB)
        RX errors 1  dropped 40  overruns 0  frame 1
        TX packets 156  bytes 9360 (9.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 42892  bytes 3619576 (3.4 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 42892  bytes 3619576 (3.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 00:00:00:00:00:00  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions `
edit retag flag offensive close merge delete

Comments

since i do not see an ip, i assume one of two problems. no dhcp active on router, or dead port on router. try a different port, and if that fails, reset the router. if still not working, set a static ip that you know matches the net config, and see if that lets you see the router. if so, then dhcp is not working.

steveebey73742 ( 2017-04-19 13:31:24 +0000 )edit

thanks for your comments. But I would like to add that I am new to this fedora os. I would be grateful if you could please inform the commands to check for dhcp status in the system. I have checked the router and the port and they are working for other devices.

debo_22 ( 2017-04-19 14:14:45 +0000 )edit

try this -

sudo ifup enp2s0 
ifconfig (to see if the interface came up)

Let me know.

steveebey73742 ( 2017-04-19 17:01:35 +0000 )edit

I tried with the two comments . But the results are the same. No additional information came up

debo_22 ( 2017-04-20 09:31:43 +0000 )edit

you say it works with other devices, so using the address information from a different device, assign your network adapter a static ip address, using the network tool in your desktop control center. make sure the address you choose is not already been assigned to another device. if that works, then check your router configuration to make sure dhcp is enabled for wired connections.

steveebey73742 ( 2017-04-20 14:02:28 +0000 )edit