cpan : loadable library and perl binaries are mismatched

asked 2017-04-21 11:21:45 +0000

didli gravatar image

Hi everyone, Since Fedora 25 (x64), I'm having issues with perl/cpan and I'm not sure where it came from and what I'm supposed to do. Basically, with slic3r (3d printing software) as an exemple, it returns this :

threads.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)

cpan return this :

HiRes.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)

The few things I understand is that I must have previously installed modules (?) in a bad way ? So, could you please help me figure out the correct procedure to solve this kind of error ? Thank you !

edit retag flag offensive close merge delete