Ask Your Question

setting acpi_backlight=vendor at grub.conf doesn't effect.

asked 2011-10-23 16:09:40 +0000

Lyoko gravatar image

updated 2011-11-26 04:29:04 +0000

mether gravatar image

I'm a former ubuntu user, and i got Asus UL30A laptop.. and I installed Fedora 15, Gnome. setting brightness by Fn keys never worked for me so I have been using official ubuntu guide for my laptop at: https://wiki.ubuntu.com/AsusUL#Hotkeys

Since there is no update-grub command nor /etc/default/grub.conf file I tried to add manually "acpibacklight=vendor acpiosi=linux" (without these " ") to my grub.conf at /boot/grub/ and it doesn't affect anything.

I have tested setting brightness using terminal and it did work, and i don't want any work arounds.

Thanks everyone!

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted

answered 2011-10-25 03:02:45 +0000

Where did you add them in grub.conf? they should be on the same line as 'rhgb quiet' are.

Your best bet is to file a bug against the Fedora kernel package and get maintainers to look at it and hopefully fix it for you. See:




edit flag offensive delete link more

answered 2011-11-10 11:06:40 +0000

place so, acpi_osi=Linux, and use the 'L' uppercase, not lowercase ...

edit flag offensive delete link more

answered 2011-11-09 19:06:54 +0000

kiilerix gravatar image

This should work out of the box without any boot parameters. Have you tried with Fedora 16?

Anyway: check /proc/cmdline to see if the workaround parameter was handed over to the kernel correctly. That will tell you if the problem is related to grub2 or to the kernel.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

1 follower


Asked: 2011-10-23 16:09:40 +0000

Seen: 8,509 times

Last updated: Nov 10 '11