English
Ask Your Question
1

Reduce Grub Time in Fedora 25

asked 2017-05-15 22:26:40 +0000

gtomas gravatar image

Hi,

when I edit /etc/default/grub to reduce the GRUB time while booting fedora from 5 to 2 seconds, I save the file, but upon restart, the grub time is agian set to 5 seconds.

Is there some kind of update grub I should do?

Thanks.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
3

answered 2017-05-21 17:12:25 +0000

sixpack13 gravatar image

updated 2017-05-21 17:15:54 +0000

[ -d /sys/firmware/efi/efivars ] && echo EFI || echo Legacy Bios

=> EFI

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
edit flag offensive delete link more
2

answered 2017-05-15 23:00:15 +0000

grub2-mkconfig -o /boot/grub2/grub.cfg

edit flag offensive delete link more

Comments

Works, thanks!

gtomas ( 2017-05-16 06:41:51 +0000 )edit

Actually, it doesn't. It's been updated, I even installed Grub Customizer, and the Grub timeout is 2 seconds, but it still couts down from 5 when i boot it?

gtomas ( 2017-05-20 18:35:14 +0000 )edit

You probably have an EFI system, see the other answer...

florian ( 2017-05-22 02:37:14 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-05-15 22:26:40 +0000

Seen: 291 times

Last updated: May 21 '17