English
Ask Your Question
0

F25 chkconfig upgrade fails

asked 2017-05-18 14:11:47 +0000

archlight gravatar image

Today I upgraded Fedora from F23 to F25.

Everything went well but "chkconfig" fails to upgrade. Here's the output from "dnf upgrade":

Upgrading: chkconfig x86_64 1.8-1.fc25 fedora 179 k

Running transaction check

Transaction check succeeded.

Running transaction Upgrading : chkconfig-1.8-1.fc25.x86_64 1/2

Error unpacking rpm package chkconfig-1.8-1.fc25.x86_64

Error unpacking rpm package chkconfig-1.8-1.fc25.x86_64

error: unpacking of archive failed on file /etc/init.d: cpio: rename

chkconfig-1.8-1.fc25.x86_64 was supposed to be installed but is not!

Verifying : chkconfig-1.8-1.fc25.x86_64 1/2

chkconfig-1.7-1.fc23.x86_64 was supposed to be removed but is not!

Verifying : chkconfig-1.7-1.fc23.x86_64 2/2

Failed: chkconfig.x86_64 1.8-1.fc25

Did anyone encountered this issue or have some insight how to resolve it? Thank you!

edit retag flag offensive close merge delete

Comments

did everything else upgrade correctly and have you restarted?

jlozadad ( 2017-05-18 19:17:42 +0000 )edit

Yes, everything else went well and upgraded correctly. I restarted the system.

archlight ( 2017-05-19 06:17:24 +0000 )edit

6 answers

Sort by ยป oldest newest most voted
1

answered 2017-05-19 05:15:54 +0000

subpop gravatar image

Try clearing your packages cache and upgrade it again. Maybe the package on the mirror you downloaded it from was bad.

dnf clean packages && dnf update

edit flag offensive delete link more

Comments

I just run clean packages and update, the result is the same as described in the original post, failed to upgrade "chkconfig".

archlight ( 2017-05-19 06:09:01 +0000 )edit
0

answered 2017-05-20 01:07:19 +0000

Try:

dnf upgrade-to chkconfig-1.8-1

I hope it works!

edit flag offensive delete link more

Comments

Unfortunately that produces the same error as mentioned earlier.

archlight ( 2017-05-22 07:54:45 +0000 )edit
0

answered 2017-06-08 22:52:46 +0000

Since I can't really reproduce the problem, I am (still) flying blind. If your are still dealing with this problem, here are addition things to try.

This is a sledgehammer approach. It will cause dnf to complain until the next successful update about changes made outside of dnf.

Make sure dnf-plugins-core package is installed.

dnf list installed dnf-plugins-core

If it is not installed, install it.

sudo dnf install dnf-plugins-core

Download the chkconfig-1.8 RPM file.

dnf download chkconfig-1.8

Install this package using the rpm --install --replacefiles --replacepkgs command or rpm --install --force command.

sudo rpm --install --replacefiles --replacepkgs chkconfig-1.8-1.fc25.x86_64.rpm

or

sudo rpm --install --force chkconfig-1.8-1.fc25.x86_64.rpm

If the package successfully installs, see what is reported by dnf as installed.

dnf list installed chkconfig

If both versions are listed use dnf to remove the chkconfig-1.7. If this succeeds, to make sure chkconfig-1.8 is consistent, I would reinstall chkconfig-1.8.

sudo dnf remove chkconfig-1.7

sudo dnf reinstall chkconfig-1.8

Again, I hope it solves the problem.

edit flag offensive delete link more

Comments

Unfortunately, installing rpm results in similar error: error: unpacking of archive failed on file /etc/init.d: cpio: rename error: chkconfig-1.8-1.fc25.x86_64: install failed

archlight ( 2017-06-14 14:09:50 +0000 )edit
0

answered 2017-06-09 00:40:51 +0000

steveebey73742 gravatar image

try sudo dnf remove chkconfig to get rid of 1.7. then sudo dnf clean all to clear the entire cache, followed by sudo dnf install chkconfig and since you are upgraded to F25, it should grab the latest.

edit flag offensive delete link more

Comments

It won't let me remove chkconfig, it results in error: Error: The operation would result in removing the following protected packages: systemd, sudo, systemd-udev, dnf.

archlight ( 2017-06-14 14:08:21 +0000 )edit
0

answered 2017-07-26 01:34:54 +0000

I solved it on f26 (similar problem) by renaming /etc/init.d to /etc/init.d~ and installing the new version with

# rpm --install --verbose --force chkconfig-1.10-1.fc26.x86_64.rpm
edit flag offensive delete link more
0

answered 2017-07-26 01:44:11 +0000

I had the same problem on f26 and suspected that it was because I had local init scripts in /etc/init.d. I solved it with

# dnf download chkconfig-1.10
# mv /etc/init.d /etc/init.d~ 
# rpm --install --verbose --force chkconfig-1.10-1.fc26.x86_64.rpm
# mv /etc/init.d~/<my-scripts> /etc/init.d/
# rmdir /etc/init.d~
edit flag offensive delete link more

Comments

Confirmed working. Thanks.

lhartmann ( 2017-08-02 13:21:39 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
2 followers

Stats

Asked: 2017-05-18 14:11:47 +0000

Seen: 154 times

Last updated: Jun 08