Ask Your Question

Scanner integrate with printer canon MG5750 on wifi not recognized

asked 2017-05-19 19:23:39 +0000

I have a canon printer/scanner MG5750 connected via WIFI to my centronic router. The printer work fine and was instantly recognized by Fedora 25. The scanner is not working! I suppose there is some config file I need to change.

I have set up the the printer/scanner with a static IP on the centronic router

Your help will be greatly appreciate!

edit retag flag offensive close merge delete


Edit /etc/sane.d/dll.conf, uncomment the line with net, then edit /etc/sane.d/pixma.conf putting your static IP in there. I didn't test it, I have an Epson printer/scanner, just guessing it works the same, give it a try....

fcomida ( 2017-05-20 09:48:24 +0000 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2017-05-22 08:39:17 +0000

Thank you for your comment fcomida but it doesn't seem to work; Maybe there is something to do also on the router. I will check and report the result here

edit flag offensive delete link more


You must allow traffic to/from port 8612

fcomida ( 2017-05-22 17:51:09 +0000 )edit

Canon has a package ScanGear MP Ver. 3.20 for Linux

fcomida ( 2017-05-22 18:08:09 +0000 )edit

Have a look here as well: sane-pixma

fcomida ( 2017-05-25 13:54:11 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

1 follower


Asked: 2017-05-19 19:23:39 +0000

Seen: 101 times

Last updated: May 19 '17