Ask Your Question
1

Unable to update Fedora Linux due to some conflicts that I don't completely understand.

asked 2017-05-25 07:32:26 -0500

Gunjan Garg gravatar image

updated 2017-05-25 13:57:13 -0500

Hi!

Another linux noob here. I'm Gunjan Garg. I just know how to do what I use computers for, and don't know much about linux. Almost once in three or four days I run sudo dnf update in the terminal to make sure that my Fedora Linux is up to date. I never faced any problem with update before. But today, i.e. on May-25,2017, I wasn't able to update the system. Some 37 packages cannot be installed because a new file to be installed somehow conflicts with an rpm file that is already installed. Here's the details, please be kind to help me out if you think you can and have some time to waste... Thanks a lot.

Following the ten backslashes after the next sentence, you will find the terminal output for sudo dnf update. This output includes the sentence:

file /usr/lib/gstreamer-1.0/libgstrawparse.so conflicts between attempted installs of gstreamer1-plugins-bad-free-1.10.4-1.fc25.i686 and gstreamer1-plugins-base-1.11.91-2.fc25.i686

\\\\\

[gunjan@localhost ~]$ sudo dnf update

Last metadata expiration check: 0:29:46 ago on Thu May 25 16:55:22 2017.

Dependencies resolved.

======================================================================================

Package

======================================================================================

Upgrading:

autocorr-en

ffmpeg

ffmpeg-libs

gstreamer1-plugins-bad-free

gstreamer1-plugins-bad-free-extras

gstreamer1-plugins-bad-free-gtk

gstreamer1-plugins-base

gstreamer1-plugins-base-devel

gstreamer1-plugins-base-tools

gtk-update-icon-cache

gtk3

gucharmap

gucharmap-libs

libavdevice

libreoffice-calc

libreoffice-core

libreoffice-data

libreoffice-draw

libreoffice-emailmerge

libreoffice-filters

libreoffice-graphicfilter

libreoffice-gtk2

libreoffice-gtk3

libreoffice-impress

libreoffice-langpack-en

libreoffice-math

libreoffice-ogltrans

libreoffice-opensymbol-fonts

libreoffice-pdfimport

libreoffice-pyuno

libreoffice-ure

libreoffice-ure-common

libreoffice-writer

libreoffice-x11

libreoffice-xsltfilter

libreofficekit

mint-x-icons

qt-remote-viewer

qt-virt-manager

xfce4-terminal

Transaction Summary

======================================================================================

Upgrade 40 Packages

Total size: 135 M

Is this ok [y/N]: y

Downloading Packages:

[SKIPPED] autocorr-en-5.2.7.2-3.fc25.noarch.rpm: Already downloaded

[SKIPPED] ffmpeg-3.1.8-1.fc25.i686.rpm: Already downloaded

[SKIPPED] ffmpeg-libs-3.1.8-1.fc25.i686.rpm: Already downloaded

[SKIPPED] gstreamer1-plugins-bad-free-1.10.4-1.fc25.i686.rpm: Already downloaded

[SKIPPED] gstreamer1-plugins-bad-free-gtk-1.10.4-1.fc25.i686.rpm: Already downloaded

[SKIPPED] gstreamer1-plugins-bad-free-extras-1.10.4-1.fc25.i686.rpm: Already downloaded

[SKIPPED] gstreamer1-plugins-base-1.11.91-2.fc25.i686.rpm: Already downloaded

[SKIPPED] gstreamer1-plugins-base-tools-1.11.91-2.fc25.i686.rpm: Already downloaded

[SKIPPED] gstreamer1-plugins-base-devel-1.11.91-2.fc25.i686.rpm: Already downloaded

[SKIPPED] gtk-update-icon-cache-3.22.15-1.fc25.i686.rpm: Already downloaded

[SKIPPED] gtk3-3.22.15-1.fc25.i686.rpm: Already downloaded

[SKIPPED] gucharmap-9.0.4-1.fc25.i686.rpm: Already downloaded

[SKIPPED] gucharmap-libs-9.0.4-1.fc25.i686.rpm: Already downloaded

[SKIPPED] libavdevice-3.1.8-1.fc25.i686.rpm: Already downloaded

[SKIPPED] libreoffice-calc-5.2.7.2-3.fc25.i686.rpm: Already downloaded

[SKIPPED] libreoffice-core-5.2.7.2-3.fc25.i686.rpm: Already downloaded

[SKIPPED] libreoffice-data-5.2.7.2-3.fc25.noarch.rpm: Already downloaded

[SKIPPED] libreoffice-pyuno-5.2.7.2-3.fc25.i686.rpm: Already downloaded

[SKIPPED] libreoffice-ure-5.2.7.2-3.fc25.i686.rpm: Already downloaded

[SKIPPED] libreoffice-gtk3-5.2.7.2-3.fc25.i686.rpm: Already downloaded

[SKIPPED] libreoffice-langpack-en-5.2.7.2-3.fc25.i686.rpm: Already downloaded

[SKIPPED] libreoffice-opensymbol-fonts-5.2.7.2-3.fc25.noarch.rpm: Already downloaded

[SKIPPED] libreoffice-ure-common-5.2.7.2-3.fc25.noarch.rpm: Already downloaded

[SKIPPED] libreoffice-filters-5.2.7.2-3.fc25.i686.rpm: Already downloaded

[SKIPPED] libreoffice-draw-5.2.7.2-3.fc25.i686.rpm: Already downloaded

[SKIPPED] libreoffice-graphicfilter-5.2.7.2-3.fc25.i686.rpm: Already downloaded

[SKIPPED ... (more)

edit retag flag offensive close merge delete

Comments

see if using sudo dnf remove gstreamer1-plugins* will let the upgrade finish, then use sudo dnf install gstreamer1-plugins* to put them back. as to your original question, if you edit, and select the text from terminal, then click the square on the edit toolbar that has the 101010 on it, it will preformat the text for a better display. I would also recommend running sudo dnf clean packages first, just to make it download fresh copies.

steveebey73742 gravatar imagesteveebey73742 ( 2017-05-25 08:10:03 -0500 )edit

Thanks steveebey73742 for teaching me that stuff about the 101010 toolbar. I didn't know that!

I ran the command sudo dnf clean packages, and 40 packages were removed.

Then, I ran sudo dnf remove gstreamer1-plugins* and the terminal said that 790 installed packages will have to be removed. I find this scary. I'll prefer 'never updating the Linux system' to 'screwing it and reinstalling a Linux system'. Everything on this Fedora Linux is working. I'm just unable to update.

Are you quite certain that if I go on to type 'y' and let it remove 790 packages, the system will still work perfectly?

Gunjan Garg gravatar imageGunjan Garg ( 2017-05-25 09:20:52 -0500 )edit
1

Don't remove the 790 packages. It will most likely kill your system!

To update your system, and skip the broken gstreamer dependency, you can run sudo dnf upgrade --best. Check man dnf for a description of that function.

florian gravatar imageflorian ( 2017-05-25 10:55:52 -0500 )edit

I agree with @florian, 790 sounds ecessive. instead of using a wildcard, try removing them by using the full name of the package. I actually had those same 2 present this morning, on my updates, so now I am waching to see how it does for me.

steveebey73742 gravatar imagesteveebey73742 ( 2017-05-25 11:58:48 -0500 )edit

So, I am now waiting to see if the problem gets resolved because of some major change that takes place within a few days/weeks. As of now I am not able to update because of that error message. And agreeing with florian, I am not removing any package.

steveebey73742 please let me know how you dealed with those two packages if you update your system successfully.

thanks for telling me about 'upgrade --best' florian. I'll read man dnf for the descriprion after posting this comment.

Thanks davidva. I had installed the gstreamer packages with Fedora. I did it to watch all videos and play songs.

Gunjan Garg gravatar imageGunjan Garg ( 2017-05-25 13:50:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
4

answered 2017-05-26 02:53:08 -0500

villykruse gravatar image

The conflict is between gstreamer1-plugins-bad-free-1.10.4-1.fc25.i686 from the fedora project and gstreamer1-plugins-base-1.11.91-2.fc25.i686 probably from https://unitedrpms.github.io/

Unitedrpms is the only place I could find which provides version 1.11 of gstreamer1-plugins-base and the latest version from the fedora project is currently version 1.10.

Unless you really need unitedrpms, I suggest you disable that repository.

edit flag offensive delete link more

Comments

1

The people needs read; Is this difficult? man!!! https://github.com/UnitedRPMs/WIKI/wi...

davidva gravatar imagedavidva ( 2017-05-26 18:25:01 -0500 )edit

Thanks Villykruse. You posted the exact solution to this problem. I have marked your solution as correct. The problem is now solved. I disabled the unitedrpms repository and the 37 packages got successfully installed. No error message was displayed after I disabled that repository. Thanks again.

Davidva may be correct when he thinks that this solution was obvious. But, to me, it seemed quite complicated. Once I spent about half an hour searching the web for 'conflicts during updates' I felt that the issue was showing up somewhat; and I decided to post it here.

Thanks everyone, for your time.

Gunjan Garg gravatar imageGunjan Garg ( 2017-05-26 20:51:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-25 07:32:26 -0500

Seen: 775 times

Last updated: May 25 '17