Install F17 package in F18

asked 2013-01-25 03:24:58 +0000

wraeth gravatar image

I have an issue with a video driver. I've tried getting help debugging it but that hasn't really panned out. I've determined that the next course of action is to try an older driver version, but the driver version I know to work is not available in the F18 repository.

I've upgraded my laptop from F17 to F18 using a clean install from DVD. I've figured out that the version of the driver in F18 is 0.10.8, and in the F17 repo is 0.10.4. I enabled the F17 repo, but when I try to install the package I get the following:

yum install xorg-x11-drv-sis-0.10.4-1.fc17.i686
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package xorg-x11-drv-sis.i686 0:0.10.4-1.fc17 will be installed
--> Processing Dependency: xserver-abi(videodrv-12) >= 0 for package: xorg-x11-drv-sis-0.10.4-1.fc17.i686
--> Finished Dependency Resolution
Error: Package: xorg-x11-drv-sis-0.10.4-1.fc17.i686 (fedora-17)
           Requires: xserver-abi(videodrv-12) >= 0
           Available: xorg-x11-server-Xorg-1.12.0-2.fc17.i686 (fedora-17)
               xserver-abi(videodrv-12) = 0
           Installed: xorg-x11-server-Xorg-1.13.1-4.fc18.i686 (@updates)
               Not found
           Available: xorg-x11-server-Xorg-1.13.0-11.fc18.i686 (fedora)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Is there a way to install a package from the F17 repository while either ignoring dependencies or translating dependencies to the F18 repository?

Cheers.

edit retag flag offensive close merge delete