English
Ask Your Question
1

No audio in Wine

asked 2017-06-17 01:09:13 +0000

thesuperpapagai gravatar image

I am trying to run games in Wine on Fedora 25 via PlayOnLinux, however when they load, none of them have audio. I was able to play the same games fine on other distros, but they do not work with Fedora. Using a different version of WIne also does not fix this problem.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-06-17 07:28:39 +0000

fcomida gravatar image

Wine can output sound through alsa and pulseaudio. In Fedora there is wine-pulseaudio but since you are installing wine through Playonlinux you probably need to install alsa-plugins-pulseaudio `

edit flag offensive delete link more

Comments

1

I already have wine-pulseaudio, wine-alsa and alsa-plugins-pulseaudio installed

thesuperpapagai ( 2017-06-18 02:41:03 +0000 )edit

Since PlayOnLinux scripts usually install and use different versions of wine for each game/program, system-wide wine installation isn't relevant in many cases. Anyway have you run winecfg and looked at audio section there? There's also a test audio button. I'm on F24, no audio problems in wine at all here.

fcomida ( 2017-06-18 06:17:41 +0000 )edit

After a lot of messing about with Wine I found the very best version was the official stable version direct from the creators:

sudo dnf config-manager --add-repo https://dl.winehq.org/wine-builds/fedora/25/winehq.repo
sudo dnf install winehq-stable

This version has pulse audio installed out-the-box, you should not need to do anything else to get sound.

David-LDA ( 2017-06-18 10:43:19 +0000 )edit

When I use the Test Audio button I get sound, but I don't get sound in the wine game itself.

thesuperpapagai ( 2017-06-18 12:01:43 +0000 )edit

@thesuperpapagai as I said each game on POL has its own version of wine installed under ~/.PlayOnLinux/wine/. You must select a game and run configure and then winecfg from there. I'm not sure whether those local installations of wine have proper support for pulseaudio or not and if this is the case whether your system is properly configured to output sound for alsa only programs through alsa-plugins-pulseaudio or not. Do you have ~/.asoundrc in your home? It should look like this

fcomida ( 2017-06-18 13:46:00 +0000 )edit
0

answered 2017-06-17 02:41:24 +0000

Barrelwolf38087 gravatar image

Did you build WINE yourself? WINE requires OSSv4 at compile-time to play most sound. If you didn't build it yourself, you might want to give that a try. The instructions to do so can be found here.

edit flag offensive delete link more

Comments

Where did you get this information?

fcomida ( 2017-06-17 07:31:48 +0000 )edit

@fcomida hi downvoter...

@Barrelwolf38087 OSSv4 isn't used anymore in moderns linux distros... the problem is here: http://pkgs.fedoraproject.org/cgit/rp...

davidva ( 2017-06-18 05:20:30 +0000 )edit

@davidva ?????

fcomida ( 2017-06-18 06:01:08 +0000 )edit

@fcomida I got that information when I built WINE from source of Fedora. Had to build OSS, too. Unfortunately, that installation is gone.

Barrelwolf38087 ( 2017-06-19 03:31:54 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-06-17 01:09:13 +0000

Seen: 72 times

Last updated: Jun 17