English
Ask Your Question
0

Setup hybrid graphics on a Slimbook Excalibur

asked 2017-06-18 15:54:50 +0000

I recently bought a Slimbook Excalibur with Fedora 25 pre-installed and I'd like to make the hybrid graphics work. The details are:

  • Integrated card: Intel® HD Graphics 520 (Skylake GT2)
  • Dedicated card: NVIDIA GeForce 940M

The lspci output is:

00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 20)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 20)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 20)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 20)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f0)
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 20)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 20)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 20)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 20)
01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940MX] (rev a2)
02:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

Right now I'm running the kernel version 4.11.5-200.fc25.x86_64. So far I've tried with the indications at https://negativo17.org/nvidia-driver/ but I wasn't able to succeed. The package installation has created a xorg.conf like:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 381.22  (buildmeister@swio-display-x86-rhel47-02)  Thu May  4 01:29:00 PDT 2017

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

But still, when I log in using using a Wayland session, only the integrated card is detected and used. Actually If I try to open nvidia-settings it fails with the error:

ERROR: Unable to find display on any available system

On the other hand, If I try to log in using Xorg, it just freezes. How could I make it work on Wayland? And on the other hand If's easier / better, how could I debug the Xorg session to see what's failing?

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2017-06-21 20:58:11 +0000

Nvidia Optimus Laptop are supported easily since Fedora 25 using the Nvidia driver. This requires no change from the usual packaged installation process.

Please follow the official RPM Fusion documentation for Nvidia https://rpmfusion.org/Howto/NVIDIA

And the section for Optimus https://rpmfusion.org/Howto/Optimus

In your case, you shouldn't even need to use nvidia-xconfig, so you will have to remove the generated /etc/X11/xorg.conf And possibly clean conflicting libraries created by the nvidia installer.

edit flag offensive delete link more
0

answered 2017-06-20 09:59:09 +0000

ozeszty gravatar image

On F25 release Wayland would not work on nvidia hardware with proprietary drivers, I don't know they fixed it. Anyway, Xorg should be working, maybe some factory added config is interfering with your driver? Looking at this I'd say try removing it:

sudo rm -rf /etc/X11/xorg.conf.d/20-nvidia.conf

If this doesn't make Xorg work, reinstall nvidia driver. You may also undo what you installed following negativo17.org and use this guide on installing bumblebee in Fedora.

edit flag offensive delete link more

Comments

Yeap, Wayland on Nvidia blob on laptops is expected in F27, more info here.

ozeszty ( 2017-06-20 17:48:15 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-06-18 15:54:50 +0000

Seen: 141 times

Last updated: Jun 21