English
Ask Your Question
2

Touchpad Issues Still Not Fixed in Fedora 18

asked 2013-01-31 17:31:50 +0000

Jayson Wonder gravatar image

updated 2014-12-23 18:23:23 +0000

mether gravatar image

Hello,

Update, I have been playing with the live version of this before install and I see I still have the same issues and there has been no resolution on this. How can it be totally ignored? Is there any way to fix this problem. I sure other people has this problem. Please help me.

I am using a MSI Wind L1350 Netbook with Fedora 17. Overall quite happy with performance and functionality. I do however have 1 major issue. I cannot figure out how to turn off tapping on my touchpad. I absolutely despise tapping and my thumbs constantly hit the pad on such small keyboard.

I have tried the mouse and touchpad setting in Gnome where you would think this would be but there is no tab there for touchpad just mouse settings which I find weird.

I attempted to turn it off in the /usr/share/X11/xorg.conf.d/ with the files in there such as: 10-evdev.conf 10-quirks.conf 50-synaptics.conf~ 50-wacom.conf 10-evdev.conf~ 50-synaptics.conf 50-vmmouse.conf

Still no luck maybe I not editing it correctly.

There has got to be a simple way to turn off this tapping. Please any help is greatly appreciated!

Thanks,

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2013-01-31 17:48:20 +0000

updated 2013-01-31 17:48:40 +0000

Personally I use syndaemon. I run it on login.

syndaemon -t -k -i 2 -d

-i 2 sets the idle time to 2 seconds. The idle time specifies how many seconds to wait after the last key-press before enabling the touchpad again. -t tells the daemon not to disable mouse movement when typing and only disable tapping and scrolling. -k tells the daemon to ignore modifier keys when monitoring keyboard activity (e.g.: allows Ctrl+Left Click). -d starts as a daemon, in the background.

More details are available in the man page:

man syndaemon

Otherwise mouse configuration varies by window manager.

See also: http://groveronline.com/2012/05/shorter-trackpad-disabling-timeout-with-gnome-3-fedora-17/

edit flag offensive delete link more
0

answered 2013-07-02 00:42:45 +0000

The syndaemon command, strangely, works on my FC18 laptop, but not on my wife's FC18 laptop. Not at all sure why. I'm working on that, but we need a solution faster than I can figure out why it works on my laptop but not hers. (Identical machines.)

But I found this at RPM Sphere, a version of the synaptics (synaptiks) touchpad driver that allows you to turn off tapping. No keyboard delay, but it at least turns it off and still allows pointer movement.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2013-01-31 17:31:50 +0000

Seen: 3,022 times

Last updated: Jul 02 '13