Ask Your Question
0

Dosemu don't works with Dbase

asked 2017-06-29 07:45:43 -0500

I installed dosemu but it does not work with the dbase IV program. When I try to run Dbase, it uses more than 45% of the CPU and shows nothing on the screen indefinitely

Please, any idea?

edit retag flag offensive close merge delete

Comments

Dbase used a form of copy protection, by marking the hard drive with a secret code file. Did you install Dbase after running Dosemu, or did you just copy it from a working install? copy will not work, since the files that are part of the security do NOT get copied.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-06-29 12:59:44 -0500 )edit

I use this copy of Dbase on several machines and various operating systems and I have done this for over 20 years and have never had this kind of problem. This problem started now that I'm trying to use Fedora. In other distributions this does not happen.

sergiogelli gravatar imagesergiogelli ( 2017-07-19 05:39:22 -0500 )edit

okay, try this. sudo setenforce=0 to put selinux in permissive mode. the mode setting is permanent until changed by you again, even a reboot will not reset it.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-07-19 08:44:16 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-07-19 05:34:06 -0500

DosBox has a feature that does not work for the system I already have and is ready to work with Dosemu.

I tried to see some instruction on the link you sent me, but it's a very advanced subject for me.

Would anyone have a simpler solution to my problem, other than abandon Fedora? For other distributions DBase IV works normally with Dosemu.

edit flag offensive delete link more

Comments

The simple version is that the kernel feature that made dosemu fast has been disabled by default for security reasons and lack of maintenance. It also mentions that it doesn't even work on a 64-bit kernel. I'm surprised that other distributions override the default in this case. As I mentioned in my answer, you would be much better off using a virtual machine instead.

ssieb gravatar imagessieb ( 2017-07-19 13:57:25 -0500 )edit
0

answered 2017-06-29 13:22:32 -0500

ssieb gravatar image

VM86 mode has been disabled by default in the kernel. See https://lkml.org/lkml/2015/7/9/548 for some info. You could try dosbox and see if that works any better. But I would suggest using a virtual machine instead as that will give you extremely better performance because it will use the real CPU instead of emulating it.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-06-29 07:45:43 -0500

Seen: 42 times

Last updated: Jun 29 '17