English
Ask Your Question
3

Fedora 25 Installation Fail

asked 2017-06-30 19:44:07 +0000

opt1mal gravatar image

updated 2017-07-01 17:13:15 +0000

When installing on my laptop - Windows 10 - the installation will stop when it gets to Starting Network Manager Script Dispatching Service or after. Here is a picture to show what I mean.image description

I have an i7 Core, 16GB Ram, and Nvidia GeForce 960M. I have already asked this question on another site and someone has said they do not know how to fix it, but it may be due to my GPU being Nvidia, Any answers would be great!

Thank you, opt1mal

edit retag flag offensive close merge delete

Comments

1

If the issue is with the live dvd install try the compatibility mode. Good Luck.

aeperezt ( 2017-07-01 02:08:14 +0000 )edit

How would I install from compatability mode? Also, would I put an anaconda tag since my USB says Anaconda when plugged in? It is a SanDisk 8GB USB.

opt1mal ( 2017-07-01 17:14:06 +0000 )edit

anaconda is the name of the software that installs fedora. the initial grub menu should have a troubleshoot choice, 3 down from the top, to install with low res gui, and it will let you get setup, then once you boot to the hard drive you install it on, you can get the drivers needed to make the nvidia card work.

steveebey73742 ( 2017-07-01 18:29:16 +0000 )edit
1

What drivers would I need to make the Nvidia card work. I have a Nvidia 960M(notebook series).

opt1mal ( 2017-07-05 15:29:48 +0000 )edit
1

Try installing from one of updated ISOs (currently with updates until 2017-07-04 e.g. kernel 4.11.8-200) https://dl.fedoraproject.org/pub/alt/live-respins/, maybe it will let you perform regular installation from live system.

As for Nvidia drivers it should be more convenient to use rpmfusion packaged drivers https://rpmfusion.org/Howto/NVIDIA and maybe setup PRIME Synchronization to reduce tearing.

ozeszty ( 2017-07-05 20:58:53 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2017-07-05 20:01:22 +0000

steveebey73742 gravatar image

updated 2017-07-10 01:19:43 +0000

if you want proprietary, then visit https://www.nvidia.com and select Linux 64 as your operating system. if you want akmod or negativo17 then search the forums for instructions on how to get them. I run proprietary, and when it asks to install dkms I answer yes. In order to do that, you need to have kernel-devel and kernel headers installed. You can do that with sudo dnf install kernel-devel-$(uname -r) kernel-headers-$(uname -r) gcc acpid and you only have to do this once, as dnf will keep it updated, with each kernel upgrade. Download and save the nvidia driver, then open a terminal window, do sudo init 3 and it will change to text console. then enter cd /home/username/path to download and then chmod +x NVIDIA-Linux-x86_64-xxx.xx.run but replace the xxx.xx with driver version you chose. then type lsmod | grep nouveau and if nothing comes back type ./NVIDIA-Linux-x86_64-xxx.xx.run or if nouveau showed up, then type ./NVIDIA-Linux-x86_64-xxx.xxx.run -Z and when it asks about dkms answer yes. I also choose the 32 bit compatibility, so I can run wine and windows programs. If the 32 bit come up and ask about overwrite, select install and overwrite, so that you get the most compatible installation. After the successful install, then reboot and see if everything works.

edit flag offensive delete link more

Comments

Thank you. Should I do this after installing to hard drive or before?

opt1mal ( 2017-07-06 02:45:11 +0000 )edit
1

Has to be after, to get the updates. after you are running in the low resolution display, open terminal do sudo dnf update -y then follow the steps in the answer shown here.

steveebey73742 ( 2017-07-06 12:07:49 +0000 )edit

Thank you! I will try this and see if it works.

opt1mal ( 2017-07-06 17:10:24 +0000 )edit

I installed it, but after the three dots at booting up, the underline will come up and nothing happens. Any ideas?

opt1mal ( 2017-07-07 02:55:03 +0000 )edit
1

sure. if you installed 384.47, i had the same issue the first time I tried it. then after the most recent kernel update, it works fine. since your installing, you may need to get the kernel updated, to the most recent version. You can go to nvidia.com and get an older driver, like 375.66 and see if that installs, then once all your kernel updates are done, try 384.47. I am running that one right now, no issues.

steveebey73742 ( 2017-07-07 04:12:34 +0000 )edit
0

answered 2017-07-01 15:55:12 +0000

user123 gravatar image

If you install it from live iso, try to install it from non live iso. It doesn't said to have this problem but if you want you can try.

edit flag offensive delete link more

Comments

Are you saying that I should try and install it from a disk instead of a USB? I am new to this so I am trying to make sure I am understanding everything correctly.

opt1mal ( 2017-07-01 17:11:34 +0000 )edit
1

Nobody born learned. In this case is even harder. So about your question.......... No. I'm new. I even don't have Fedora already. According to me, you didn't understand me because I made a mistake. I'll sugest you to look at this..........https://docs.fedoraproject.org/en-US/Fedora/25/html/Installation_Guide/. To read the text from to link and to try what's typed there. If it doesn't help, comment again, if you want.

user123 ( 2017-07-01 21:56:20 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
2 followers

Stats

Asked: 2017-06-30 19:43:41 +0000

Seen: 201 times

Last updated: Jul 10