Ask Your Question
2

Fedora booting taking long : below is an error

asked 2017-07-07 06:10:22 -0500

Venter gravatar image

[ TIME ] Timed out waiting for device dev-disk-by\x2duuid-279f7074\x2dba93\x2d4652\x2d8a27\x2d81dde3ed7ab7.device. [DEPEND] Dependency failed for /dev/disk/by-uuid/279f7074-ba93-4652-8a27-81dde3ed7ab7. [DEPEND] Dependency failed for Swap.

edit retag flag offensive close merge delete

Comments

test the hardware and report back the results, think you have a failed hard drive.

steveebey73742 gravatar imagesteveebey73742 ( 2017-07-07 08:12:17 -0500 )edit

After you boot in, could you please give this command into your terminal and post here the results?

systemd-analyze blame
MaoTao gravatar imageMaoTao ( 2017-07-07 10:28:17 -0500 )edit

Needs a lot more information. This message just means a swap drive is wanted (by fstab most likely but we need to see the fstab to know), but it's not found. We don't know why from the available information.

cmurf gravatar imagecmurf ( 2017-07-07 10:30:43 -0500 )edit
Venter gravatar imageVenter ( 2017-07-09 03:01:48 -0500 )edit

@cmurf results of my fstab #

/etc/fstab

Created by anaconda on Sat Jul 1 14:43:46 2017

#

Accessible filesystems, by reference, are maintained under '/dev/disk'

See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info

# UUID=4b43e8bd-18eb-4297-a07f-7bcf84471eeb / ext4 defaults 1 1 UUID=C957-A60E /boot/efi vfat umask=0077,shortname=winnt 0 2 UUID=279f7074-ba93-4652-8a27-81dde3ed7ab7 swap swap defaults 0 0

Venter gravatar imageVenter ( 2017-07-09 03:08:30 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2017-07-09 06:06:53 -0500

masteroman gravatar image

It would be easier if you edited those blocks of output and put them in code block, this way formatting gets weird.

Anyhow, seems like you've removed some device that's still specified in your fstab, boot files or initramfs. Seems like you've removed SWAP partition, is that correct? If so:

  • Make sure line referring to that UUID of swap is not in /etc/fstab
  • Make sure swap partition/that UUID is not specified in /etc/grub2.cfg or /etc/default/grub

If it is specified in Grub configuration, after editing files make sure to regenerate grub config that's on /boot:

grub2-mkconfig -o /boot/grub2/grub.cfg

Make sure that, after all of this, you re-generate your initramfs files:

dracut --regenerate-all --force
edit flag offensive delete link more
1

answered 2017-07-09 03:27:34 -0500

Venter gravatar image

As advised from the above answers I commented out the swap partitionfrom the fstab file and the problem has been sorted out. Thank you

edit flag offensive delete link more
1

answered 2017-07-08 15:29:33 -0500

sixpack13 gravatar image
check your UUID for your swap device:

blkid gives a line with the word swap in it.
compare with your enties /etc/fstab

if different:
edit your /etc/fstab so that it matches the UUID given from command blkid.

Hint 1:
if you have changed your swap device somehow you need to change that in your /etc/default/grub to be able to hibernate ! (e.g. GRUB_CMDLINE_LINUX=" resume=/dev/sdxn rhgb quiet"; x and n from blkid output)

Hint 2:
for a test to check there is no other trouble on your box regarding boot (-time) you can temporally comment out the swap line in your /etc/fstab to boot without swap.
Don't forget to reset your changes in /etc/fstab afterwards !
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-07 06:10:22 -0500

Seen: 264 times

Last updated: Jul 09 '17