English
Ask Your Question
0

SOS: Log in error after updating F15 to F16

asked 2011-11-09 04:56:40 +0000

Phoenix gravatar image

updated 2011-12-03 20:56:52 +0000

mether gravatar image

Every thing was greate before I updated fedora 15 to fedora 16 using preupgrade command. There's no errors during the update process. But when it's done. I can't log in. No matter how many times I try, I only get an error which shows a sad computer face and says that something is wrong. Does anybody else encounter this problem? Any ideas how to recovery? Thanks!!!

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2011-11-10 05:20:25 +0000

ryanlerch2 gravatar image

updated 2011-11-10 05:21:01 +0000

If the first solution does not work for you, other users have reporting a similar issue (the monitor with a sad face appearing after login). However, in this case, the desktop seems to also be somewhat responsive (the meta key brings up the gnome3 overview screen and applications can be launched from there).

SELinux seems to be causing this issue. To check if this issue is what you are hitting, try temporarily disabling SElinux by opening up a terminal and switching to root:

$ su -

then, disable SElinux:

$ setenforce permissive

log out, and log back in to your user account. Hopefully the sad face will not appear for you.

To solve this issue for good, open a terminal and switch to root again. Then run the following command (don't be alarmed if it takes a while to run)

$ restorecon -r /home

the restorecon command restores file(s) default SELinux security contexts, and this seems to solve this issue in this case.

Finally, if you turned it off, don't forget to turn SElinux back on using the command

$ setenforce enforcing

hope this helps!

edit flag offensive delete link more
0

answered 2011-11-09 06:59:47 +0000

Guest gravatar image

updated 2011-11-09 07:00:29 +0000

This could be the reason that your old gnome settings are incompatibility with gnome 3.2 and gnome-shell 3.2. execute following commands as a user.

$mkdir ~/backup $mv ~/.gnome* ~/backup/ $mv ~/.local/share/gnome-shell/extensions/* ~/backup/

then execute following commands as a root,

mkdir /root/backup

mv /usr/share/gnome-shell/extensions/* /root/backup/

then try to login.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2011-11-09 04:56:40 +0000

Seen: 1,010 times

Last updated: Nov 10 '11