Ask Your Question
1

Problems with PPPoE on Fedora 25

asked 2017-07-18 08:11:36 -0500

freeride gravatar image

Hello, I have the following problem on Fedora 25 with KDE for several weeks now. I am on a PPPoE connection to my ISP (their cable is connected directly to my computer, no router). The connection works well some of the time, somewhat works at other times and at times does not work at all. Issues that I have include:

  • not able to log in to Skype or to any microsoft service: when I type my password and hit "Sign in", nothing happens;
  • many websites load slowly;
  • many websites load at about 60-70% almost immediately, but then stop and never load the rest;
  • often, when I am filling out a form and submitting it, I either get nothing, get some sort of error or the requested page loads very slowly.

I would think this is an ISP issue, but on the same machine I also have Windows 7 (dual-boot) and have none of the above problems. Everything works fine there. So I have to assume it's something to do with Fedora. I searched a lot, but didn't find anything about this exact problem. It's mostly about PPPoE not working at all, which is not my case. I really want to keep using Fedora, but with this problem it will be very hard to.

Any help would be greatly appreciated.

edit retag flag offensive close merge delete

Comments

Welcome to ask.fedora. I very much doubt that you are using PPPOE, unless you have to log in with a username and password every time you go on line. The fact that there's no router means nothing, because you don't need one unless you have more than one computer using the same connection. Please open a terminal when you're having trouble with your connectionand run this command: ping -c10 mit.edu and copy the statistics at the bottom into a comment.

sideburns gravatar imagesideburns ( 2017-07-18 16:06:46 -0500 )edit

Does your windows use a dsl connection, to connect to your internet service? if so, did you also create a dsl connection in network manager on fedora?

steveebey73742 gravatar imagesteveebey73742 ( 2017-07-18 16:27:39 -0500 )edit

It is indeed a PPPoE connection, I have a user name and password I use to connect to the ISP. I configured it in Fedora with the "Connections - System Settings Module" as a new DSL connection and it shows up as "New pppoe connection" in the networks list. In Windows, in the "Connect to the Internet" dialog, I chose "Broadband (PPPoE)". I am writing this from Windows, because on Fedora after 7 or 8 attempts I couldn't login.

freeride gravatar imagefreeride ( 2017-07-19 03:38:49 -0500 )edit

I got this error many times: "Secure Connection Failed

The connection to the server was reset while the page was loading.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem."

This is probably the most common error I get. I also got this: "This is the Federated Open Authentication provider homepage

You will be redirected to this application whenever another application requires you to authenticate."

freeride gravatar imagefreeride ( 2017-07-19 03:42:29 -0500 )edit

Here is the output of the ping command:

$ ping -c10 mit.edu

PING mit.edu (23.9.1.159) 56(84) bytes of data. 64 bytes from a23-9-1-159.deploy.static.akamaitechn... (23.9.1.159): icmp seq=1 ttl=58 time=28.2 ms 64 bytes from a23-9-1-159.deploy.static.akamaitechn... (23.9.1.159): icmp seq=2 ttl=58 time=28.3 ms 64 bytes from a23-9-1-159.deploy.static.akamaitechn... (23.9.1.159): icmp seq=3 ttl=58 time=28.3 ms 64 bytes from a23-9-1-159.deploy.static.akamaitechn... (23.9.1.159): icmp seq=4 ttl=58 time=28.3 ms

freeride gravatar imagefreeride ( 2017-07-19 03:48:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-07-19 09:57:07 -0500

steveebey73742 gravatar image

see if the solution on this page helps your problem as well. https://ask.fedoraproject.org/en/ques...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-07-18 08:11:36 -0500

Seen: 328 times

Last updated: Jul 18 '17