English
Ask Your Question
1

firefox begin to run slower or even freeze (with php, apache)

asked 2012-05-18 23:33:27 +0000

netnitzky gravatar image

updated 2012-05-18 23:35:21 +0000

I installed apache + mysql + php. At first glance everything runs ok. The problem is: During testing simple php website from my local server the longer I work the slower firefox operates or even freeze totally. After firefox restart and httpd stop everything backs to normal operating state (particularly memory and CPU usage that was been used twice of normal level). I've been searching a proper solution for two days seeing many potential causes but I can't fix it. Did anybody do?

Some configuration steps I did: in /etc/httpd/conf/httpd.conf:

   Listen: 127.0.0.1:80
   ServerName: 127.0.0.1:80

   UserDir public_html
   <Directory /home/my_home/public_html>
        Options Indexes Includes FollowSymLinks
        Order allow,deny
        AllowOverride All
        Allow from all
   </Directory>

What KeepAlive should I set? I have 5 sec.

SELinux configuration (following alert's suggestions or just trying):

   setsebool -P httpd_enable_homedirs 1 
   chcon -R -t httpd_sys_content_t /home/my_home/public_html
   semanage fcontext -a -t httpd_sys_rw_content_t '/home/my_home/public_html'
   setsebool -P httpd_unified 1

in mozilla about:config:

network.dns.disableipv6 false->true

(it may be redundant but I'm grasping at straws) I don't know whether the cause of it is firefox or httpd, but I suppose the second one. I would be so grateful for help, it's so annoying and makes an easy work just hopeless.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2012-05-19 13:07:59 +0000

netnitzky gravatar image

updated 2012-05-19 15:16:37 +0000

I think I solved this problem myself. Excepting any other causes that may spawn similar performance of firefox (or httpd) in my case turning most add-ons off fixed the problem. Since then firefox's run great as yet and responses in right time. To say the truth most of web-dev add-ons I've disabled are now the built-in functions in firefox 12 do I don't need them longer.

Edit: Unfortunatelly, not completely. After about 2 hours of httpd running it happens again. After restart of httpd service everything turns to normal performance. Does anybody have an idea?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Stats

Asked: 2012-05-18 23:33:27 +0000

Seen: 644 times

Last updated: May 19 '12