Ask Your Question
0

Google-Chrome take too long to start up after log-out and log-in , gnome-keyring-daemon

asked 2017-07-27 15:13:29 -0600

christianbueno gravatar image

updated 2017-08-10 13:16:15 -0600

My PC characteristics:


^C tony  ~  google-chrome --version
Google Chrome 59.0.3071.115 

 tony  ~  uname -a Linux localhost.localdomain 4.11.11-300.fc26.x8664 #1 SMP Mon Jul 17 16:32:11 UTC 2017 x8664 x8664 x8664 GNU/Linux

 tony  ~  glxinfo |grep OpenGL OpenGL vendor string: nouveau OpenGL renderer string: Gallium 0.4 on NVD9 OpenGL core profile version string: 4.3 (Core Profile) Mesa 17.1.5 OpenGL core profile shading language version string: 4.30 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile OpenGL core profile extensions: OpenGL version string: 3.0 Mesa 17.1.5 OpenGL shading language version string: 1.30 OpenGL context flags: (none) OpenGL extensions: OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.1.5 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10 OpenGL ES profile extensions:  tony  ~  

Chrome take too long to start up and it log out of all my accounts, I taught that it cleared my history but it didn't
Out puts of my terminal
Errors on terminal

G tony  ~  google-chrome
[4514:4514:0810/115220.798098:ERROR:sandboxlinux.cc(344)] InitializeSandbox() called with multiple threads in process gpu-process.
Gkr-Message: secret service operation failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Gkr-Message: secret service operation failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[4399:4498:0810/115335.810849:ERROR:gcmstore_impl.cc(929)] Failed to restore security token.

 tony  ~  ps aux | grep keyring tony 2571 0.0 0.0 326812 6804 ? Sl 12:07 0:00 /usr/bin/gnome-keyring-daemon --daemonize --login tony 3784 0.0 0.0 119448 888 pts/1 S+ 12:10 0:00 grep --color=auto keyring  tony  ~  ls /etc/xdg/autostart/ |grep keyring gnome-keyring-pkcs11.desktop gnome-keyring-secrets.desktop gnome-keyring-ssh.desktop  tony  ~  


I disabled all extensions of chrome
this seems like a problem of gnome-keyring
How reproduce :

  • Log-out the pc, log in, open chrome.
    And now chrome take long to start up.
edit retag flag offensive close merge delete

Comments

Why not install chromium....

davidva gravatar imagedavidva ( 2017-07-29 13:26:09 -0600 )edit

for some reason after install seahorse , i already haven't problem

christianbueno gravatar imagechristianbueno ( 2017-08-10 13:36:11 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2017-09-03 07:54:28 -0600

christianbueno gravatar image

one solution is install "SeaHorse" from the Software Center or by terminal, open and close seahorse just in case.

edit flag offensive delete link more
0

answered 2017-08-25 21:39:39 -0600

Adding this line to /etc/pam.d/login worked for me:

auth optional pamgnomekeyring.so

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-07-27 15:13:29 -0600

Seen: 647 times

Last updated: Sep 03 '17