English
Ask Your Question
1

Screen: Turn Off After: X Locks the machine

asked 2011-11-29 20:41:10 +0000

JM gravatar image

updated 2013-08-19 06:22:12 +0000

I finally upgraded from Fredora 11 to 15 and experienced the problem described below. Then, I upgraded to Fredora 16, and am still experiencing the same problem. Both upgrades were clean installations from the respective Live File System. The machine is a Intel Dual Core Dell Dimension with a Intel 865 Chipset with 128M.

In the Screen Settings there is a setting for Turn Off After. Whatever that value is, my machine turns the monitor off at that time. But, I cannot get back into the machine via the console or the network. The monitor stays off, when I move the mouse or type on the keyboard. Additionally, the network interface goes down, so I can't even ping the machine. It does not matter whether the Lock setting is On or Off.

I am sure that there is an easy fix to this, but I can't find it in the archives here or by searching Google.

Any help is appreciated.

edit retag flag offensive close delete

Comments

The network interface really shouldn't go down. Are you sure you're changing the correct setting here?

FranciscoD_ ( 2011-11-30 06:11:50 +0000 )edit

I agree with you about the network not going down - I can't figure that one out. It is almost like it is going into suspend mode, but the light on the front is still on and I can still hear the fan running.

JM ( 2011-11-30 14:22:31 +0000 )edit

I believe that I am in the correct place: System Settings -> Screen -> Turn off after: 1 hour. I also thought that it was unusual that there is not an option to NOT turn the screen off. Also, if I lock the screen manually, the problem doesn't happen.

JM ( 2011-11-30 14:26:41 +0000 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-08-19 00:25:55 +0000

I found it was turning off my back light on my laptop, so if I use the Fn key plus the brightness control it will turn on the back light.

edit flag offensive delete publish link more
0

answered 2011-12-02 19:22:01 +0000

updated 2011-12-02 19:27:16 +0000

Can you try this below command before making your box sleep -

# xset dpms force off

Check after this when it comes back from sleep it behaves normally or not. There were previous cases where in other Fedora version network didn't come up but those were all patched up and fixed.

If the above command doesn't do the trick, please consider filling a bug report with output of dmesg, /var/log/messages and other needed details.

edit flag offensive delete publish link more

Comments

SoumyaC, I saw that on a message board as well. I tried it, but unfortunately, it didn't work either. The screen would blank for a few seconds, but the behavior was the same.

JM ( 2011-12-12 13:38:54 +0000 )edit

I ended up loading KDE to see if it was a Gnome problem. Sure enough, everything is working fine with KDE, so I will stick with that. If I can find some time, I'll play with Gnome more to try to get more information for filing a bug. Thanks.

JM ( 2011-12-12 13:40:31 +0000 )edit

If its a gnome specific bug, then file a bug in Gnome Bugzilla with the output of dmesg.

SoumyaC ( 2011-12-12 15:00:06 +0000 )edit

Your answer

Please start posting your answer anonymously - your answer will be saved within the current session and published after you log in or create a new account. Please try to give a substantial answer, for discussions, please use comments and please do remember to vote (after you log in)!

Add answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers to your questions.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question tools

Follow
1 follower

Stats

Asked: 2011-11-29 20:41:10 +0000

Seen: 1,663 times

Last updated: Aug 19 '13