Ask Your Question
5

How do I stop Package Kit from constantly searching for updates?

asked 2011-12-22 17:56:38 -0500

ransea gravatar image

updated 2012-11-05 19:14:14 -0500

mattdm gravatar image

Package Kit is running about every five minutes on my F16 machine. It's hogging a lot of resources when active.

I prefer to perform manual yum updates, and when PK is running, it holds "yum lock" until it finishes. I have no desire for automatic updates and would like to switch this feature off.

I've removed the yum - package kit plugin but this does not stop the problem.

How can I stop package kit from constantly running?

edit retag flag offensive close merge delete

Comments

If you're running F16, you'll never get any updates because it's past End Of Life. That includes security updates. Unless you have a very good reason, I'd suggest upgrading to (at least) F17.

sideburns gravatar imagesideburns ( 2013-05-02 15:03:37 -0500 )edit

I'm getting this on Fedora 21, perhaps the f21 repositories were just killed as it's way past EOL, or something. Is it intentional for PackageKit to mob users into upgrading the system?

Federico gravatar imageFederico ( 2016-05-18 14:38:44 -0500 )edit

I still have F 21 on my desktop. (Combination of hardware trouble and inertia.) I never use PackageKit, but I do know that the repositories are still there and usable.

sideburns gravatar imagesideburns ( 2016-05-18 15:13:37 -0500 )edit

Oh well, it was easier to upgrade to fedora 23 than to solve this!

Federico gravatar imageFederico ( 2016-05-20 06:15:40 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
5

answered 2011-12-22 18:22:40 -0500

ztank1013 gravatar image

updated 2011-12-22 18:25:14 -0500

Try running the following command:

sudo /usr/bin/gpk-prefs

then select Never and Nothing respectively from the Check for updates and Automatically install drop down lists.

image description

edit flag offensive delete link more

Comments

There is no such option in Fedora 21 any more.

rbu gravatar imagerbu ( 2015-04-17 03:33:18 -0500 )edit

In Fedora 21 it open Package Sources (repositories). How to disable it in Fedora 21?

skytux gravatar imageskytux ( 2015-05-08 15:27:17 -0500 )edit

Fedora 21 has a command line utility for updating gnome settings, "gsettings set org.gnome.software download-updates false". More info here: https://ask.fedoraproject.org/en/ques...

teriyakichild gravatar imageteriyakichild ( 2015-09-17 09:19:44 -0500 )edit

That's only for GNOME though

Federico gravatar imageFederico ( 2016-05-18 14:36:49 -0500 )edit
2

answered 2013-05-02 13:37:23 -0500

phorgan1 gravatar image

If you really don't want it and you're running kde anyway, just get rid of it.

sudo yum remove PackageKit

You can still add/remove/update software graphically via kde tools and via the command line with yum.

edit flag offensive delete link more
0

answered 2017-08-09 02:23:07 -0500

PackageKit can be controlled through systemd. systemctl stop packagekit systemctl disable packagekit

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-22 17:56:38 -0500

Seen: 36,275 times

Last updated: May 02 '13