English
Ask Your Question
2

Twitter media don't load in Chromium 64bit Fedora

asked 2017-08-13 11:15:17 +0000

updated 2017-08-13 19:44:32 +0000

When I open twitter and check the feed there are videos with message that media can't be played, On https://fedoraproject.org/wiki/Chromium there is info to copy libwidevinecdm.so and libwidevinecdmadapter.so to chromium directory but where I can find that file? I've tried to install chromium-widevinecdm-plugin but there are no such file and there are no widevine in chrome://flags

I've also downloaded and extracted the files from google chrome package but there no such files as well.

I've found the package on dl.google.com but there is only libwidevinecdm.so and no libwidevinecdmadapter.so and chrome://flags don't show widevine

How can I install widevine plugin for Chromium on Fedora?

I've also try to follow instruction from Video problems in twitter "The media could not be played" and [Sticky] What plugins do I need to install to watch movies and listen to music? [closed] the video is working in Firefox but not in Chromium.

https://www.youtube.com/html5 show that H.264 is not supported. How can I have that codec in Chromium? Is it possible?

edit retag flag offensive close merge delete

Comments

2 answers

Sort by ยป oldest newest most voted
1

answered 2017-08-14 05:42:48 +0000

updated 2017-08-14 18:42:25 +0000

The installation of ffmpeg, h264enc or mplayer not solves the issue, because chromium in official repositories, includes a bundled (embeded) ffmpeg, cutted, cleaned, without "proprietary" code... others answers is obsolete; exist two solutions:

Install chromium-libs-media-freeworld from rpmfusion or install chromium-freeworld from unitedrpms. Also you can install chromium-pepper-flash and chromium-widevine, from unitedrpms... ;)

edit flag offensive delete link more

Comments

I've tried all 3 solutions and they don't work, youtube say that H.264 is not present and twitter video don't work. Do you have h.264 on youtube.com/html5 in chromium? Maybe something else need to be isntalled.

jcubic ( 2017-08-15 09:34:44 +0000 )edit

I've did something and now I have 264 in chromium (I think the last thing I did was uninstall VirtualBox from rpm, that I get from official website, and install it from repo)

jcubic ( 2017-08-15 18:00:15 +0000 )edit
1

answered 2017-08-14 02:52:58 +0000

You need to install ffmpeg and codecs to install codecs install rpmfusion.org free nonfree then install h264enc now if you want all codecs install mplayer and it will install all codec dependencies. This works with firefox not sure if will work with Chromium, if it does please let us know.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-08-13 10:29:07 +0000

Seen: 56 times

Last updated: 2 days ago