Ask Your Question
2

systemd-resolved not starting on boot

asked 2017-08-15 12:55:03 -0600

firefexx gravatar image

updated 2017-08-19 11:39:25 -0600

I wanted to try systemd-networkd and systemd-resolved. While they generally seem to work well, I noticed that resolved is not starting automatically on boot despite it is enabled. I have to start it manually afterwards to get working DNS resolution.

After reboot:

# systemctl status systemd-resolved
● systemd-resolved.service - Network Name Resolution
   Loaded: loaded (/usr/lib/systemd/system/systemd-resolved.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:systemd-resolved.service(8)
           http://www.freedesktop.org/wiki/Software/systemd/resolved
           http://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
           http://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients

# systemctl start systemd-resolved

# systemctl status systemd-resolved
● systemd-resolved.service - Network Name Resolution
   Loaded: loaded (/usr/lib/systemd/system/systemd-resolved.service; enabled; vendor preset: disabled)
   Active: active (running) since Tue 2017-08-15 19:51:07 CEST; 2s ago
     Docs: man:systemd-resolved.service(8)
           http://www.freedesktop.org/wiki/Software/systemd/resolved
           http://www.freedesktop.org/wiki/Software/systemd/writing-network-configuration-managers
           http://www.freedesktop.org/wiki/Software/systemd/writing-resolver-clients
 Main PID: 1321 (systemd-resolve)
   Status: "Processing requests..."
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/systemd-resolved.service
           └─1321 /usr/lib/systemd/systemd-resolved

Aug 15 19:51:07 ... systemd[1]: Starting Network Name Resolution...
Aug 15 19:51:07 ... systemd-resolved[1321]: Positive Trust Anchors:
Aug 15 19:51:07 ... systemd-resolved[1321]: . IN DS ...
Aug 15 19:51:07 ... systemd-resolved[1321]: . IN DS ...
Aug 15 19:51:07 ... systemd-resolved[1321]: Negative trust anchors: ...
Aug 15 19:51:07 ... systemd-resolved[1321]: Using system hostname '...'.
Aug 15 19:51:07 ... systemd[1]: Started Network Name Resolution.

Does someone know what's going on there?

EDIT: I was not able to reproduce the issue on a fresh Fedora 26 installation. Maybe it was a bug that survived the upgrade path 24 -> 25 -> 26. Since it is working now, this is fine for me.

edit retag flag offensive close merge delete

Comments

The answer is probably somewhere in the log file: Run

journalctl -b | grep resolved
villykruse gravatar imagevillykruse ( 2017-08-16 02:58:15 -0600 )edit

unfortunately journalctl -b does not contain anything related to resolved or DNS

firefexx gravatar imagefirefexx ( 2017-08-17 05:15:43 -0600 )edit

1 Answer

Sort by » oldest newest most voted
-1

answered 2017-08-15 14:33:22 -0600

Aeyoun gravatar image

updated 2017-08-15 14:34:15 -0600

systemctl enable systemd-resolved

Start only starts a service once. On FreeBSD, this is called “one-start” which is more descriptive of what this command actually does. You need to enable a service to have it start with your system at boot time.

edit flag offensive delete link more

Comments

1

If you'll read the first set of output in the question, you'll see that the service is enabled, that it loaded and that it's dead. As it happens, I get the same result, right now, and I'm having no trouble with DNS. This probably isn't the issue.

sideburns gravatar imagesideburns ( 2017-08-15 15:11:06 -0600 )edit

You can't really tell what the real issue is without the full journal log since the last reboot. I have been running systemd-resolved since fedora 25 without problems on my xfce fedora system.

villykruse gravatar imagevillykruse ( 2017-08-17 08:13:12 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-08-15 12:55:03 -0600

Seen: 662 times

Last updated: Aug 19 '17