Ask Your Question
2

Switching spin desktop environment

asked 2017-08-18 05:25:58 -0500

wolfv gravatar image

updated 2017-08-18 14:53:39 -0500

I was running Fedora 26 Workstation with Gnome 3.24.2 Then I installed LXDE as described on https://fedoraproject.org/wiki/SwitchingDesktopEnvironments

$ dnf grouplist -v
...
$ sudo dnf install @lxde-desktop-environment
...
Complete!

And rebooted twice.

On the login screen, after clicking display manager (gear icon). Selecting GNOME opens GNOME as expected. Selecting LXDE also opens GNOME, I was expecting LXDE. I tried this 8 time, same result every time.

How to switch to LXDE? Or how to trouble shoot this?

edit retag flag offensive close merge delete

Comments

I believe lxde runs on top of gnome, so not sure what it should do that is different. cinnamon is what i run, and it is NOT running on top of gnome, but can use gnome programs and extensions. it is a low memory, fast gui that I enjoy.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-08-18 07:23:23 -0500 )edit

@steveebey73742 actually, it is the other way around ;)

hedayat gravatar imagehedayat ( 2017-08-18 08:40:44 -0500 )edit

@wolfv I guess you should check system logs after trying to login with LXDE to see what's wrong. BTW, it'd be more normal if you would return back to the login screen but logging in to gnome when selecting lxde is simply wrong....

hedayat gravatar imagehedayat ( 2017-08-18 08:41:44 -0500 )edit

@hedayat, what is the other way around?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-08-18 15:54:54 -0500 )edit

If anything is running on top of Gnome, it is cinnamon (but I should admit that apparently it is no longer 'running on top of gnome' as it has diverged from it (although still more tied to GNOME than others). But originally, it was just a fork of Gnome shell over Gnome.

However, desktops such as LXDE & XFCE did never run on top of GNOME. They use GTK, but don't share much else with GNOME. More info: https://en.wikipedia.org/wiki/Cinnamo...

hedayat gravatar imagehedayat ( 2017-08-19 03:39:54 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-08-18 14:54:40 -0500

wolfv gravatar image

updated 2017-08-18 15:03:27 -0500

5 hours later I come back to my PC, and Gnome says software updates are available, so I did that. Now selecting LXDE from display manager opens LXDE as it should.

edit flag offensive delete link more

Comments

:)) Great!

hedayat gravatar imagehedayat ( 2017-08-18 15:38:02 -0500 )edit
0

answered 2017-08-18 06:53:27 -0500

avramoff gravatar image

The above is correct, but would like to add, that could add another Desktop Environment, keeping the current one, and use them both with the same setting on it, but with the specific different apps for every Spin. And the URL is wrong. Here is the correct one: https://fedoraproject.org/wiki/SwitchingDesktopEnvironments

There is no any other instructions, as those, in the fedoraproject.org/wiki/'s on how to add another Spin, and keep the current...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-08-18 05:25:58 -0500

Seen: 584 times

Last updated: Aug 18 '17