Ask Your Question
0

how to stop cupsd?

asked 2012-08-09 16:21:08 -0500

mumblyjoe gravatar image

Running Fedora release 16 (Verne). Really not liking systemd.

No matter how many times I disable or stop the cups "service", it is never stopped or disabled. Below is an example. I'm betting the mysterious "Job canceled"(sic) message has something to do with it.

Worse yet, if I kill the daemon manually, a "lpstat -a" will restart it! D'oh!

# systemctl disable cups.service
# systemctl stop cups.service
Job canceled.
# systemctl status cups.service
cups.service - CUPS Printing Service
          Loaded: loaded (/lib/systemd/system/cups.service; disabled)
          Active: active (running) since Thu, 09 Aug 2012 14:05:23 -0700; 31s ago
        Main PID: 21196 (cupsd)
          CGroup: name=systemd:/system/cups.service
                  ├ 21196 /usr/sbin/cupsd -f
                  └ 21198 cups-polld 147.34.24.81 631 600 631

#  systemctl list-units |grep cups
cups.path                 loaded active waiting       CUPS Printer Service Spool
cups.service              loaded active running       CUPS Printing Service
cups.socket               loaded active running       CUPS Printing Service Sockets
edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2012-12-17 11:45:00 -0500

David Strauss gravatar image

This will forcibly take down and keep down CUPS:

systemctl disable cups.socket cups.path cups.service
systemctl kill --signal=SIGKILL cups.service
systemctl stop cups.socket cups.path
edit flag offensive delete link more
1

answered 2013-05-23 13:26:16 -0500

sergiomb gravatar image

updated 2013-05-23 13:28:10 -0500

to stop:

systemctl stop cups.socket cups.path cups.service

systemctl status  cups.service

(...) Stopped CUPS Printing Service.

to start:

systemctl start cups.socket cups.path cups.service

systemctl status  cups.service

cups.service - CUPS Printing Service
Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled) Active: active (running) since Qui 2013-05-23 19:24:58 WEST; 8s ago Main PID: 18045 (cupsd)
CGroup: name=systemd:/system/cups.service └─18045 /usr/sbin/cupsd -f

Mai 23 19:24:58 segulix systemd[1]: Started CUPS Printing Service.

edit flag offensive delete link more
0

answered 2012-12-17 22:18:30 -0500

sideburns gravatar image

If disabling cups doesn't work try using mask:

systemctl mask cups.service systemctl stop cups.service

Mask is a rather heavy-handed way to disable things, as it links the units to /dev/null and that makes it impossible to start them. Still, if simply disabling cups doesn't work you may well need to use the bigger hammer.

edit flag offensive delete link more
0

answered 2012-08-10 09:56:44 -0500

Try this:

systemctl disable cups.socket cups.path cups.service
systemctl stop cups.service
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-09 16:21:08 -0500

Seen: 24,192 times

Last updated: May 23 '13