Ask Your Question
5

F26 Gnome 3.24 - wifi icon shows as a question mark

asked 2017-09-06 13:49:56 -0500

tim8723 gravatar image

updated 2017-09-07 08:31:05 -0500

All of a sudden (last few days) the wifi connection in the Gnome panel on the top right shows as a question mark instead of a wifi symbol. The connection is working perfectly, though. So, it is not a terrible problem, but it is irritating.

I have searched the internet several times, and all I can find is people reporting the same thing, but no actual solutions. I have tried downing the connection and bringing it back up, and rebooting the PC, but the icon continues to display as a question mark. Does anyone know a solution?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
7

answered 2017-09-07 15:35:23 -0500

Aeyoun gravatar image

updated 2017-09-07 15:37:11 -0500

All that question mark indicates is whether or not you can fetch http://fedoraproject.org/static/hotspot.txt. The test server may have been down temporarily, it could be a caching issue either on your or your ISP’s end, or maybe your router blocks the URL (either with a custom content filter or a malware list). It could even be that your DNS provider failed to answer queries about the test domain.

It’s hard to tell. What I can tell you is that you needn’t worry about it if your network is indeed working fine for you. If you really want to kick it and see what happens, try systemctrl restart NetworkManager.

edit flag offensive delete link more

Comments

1

Ah, thank you. At the time I was experiencing the trouble, I was also unable to access ask.fedoraproject.org and the Fedora documentation site. I later saw on reddit that many others were experiencing the same difficulties accessing fedoraproject web stes. I'd bet that is the reason I was having the problem.

tim8723 gravatar imagetim8723 ( 2017-09-07 18:25:38 -0500 )edit
0

answered 2017-09-11 18:36:12 -0500

Nicholas gravatar image

I was experiencing a similar issue, in my case, connecting to a wireless network was fine, but I was unable to resolve anything. I eventually fixed the issue with this line in the dhclient.conf file:

sudo bash -c 'printf "send dhcp-client-identifier = hardware;\n" > /etc/dhcp/dhclient.conf'

Fun reading:

https://bugzilla.redhat.com/show_bug....

https://bugzilla.redhat.com/show_bug....

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2017-09-06 13:49:56 -0500

Seen: 2,488 times

Last updated: Sep 11 '17