Ask Your Question
0

LibreOffice rendering issue after last update

asked 2017-09-06 15:51:59 -0500

patocarr gravatar image

updated 2017-09-06 16:52:45 -0500

Hi folks,

Using up-to-date Fedora 26 Workstation, kernel 4.12.9-300. After the last update a couple of days ago, LibreOffice 5.3.6.2 (also in previous 5.3.4.1) started having rendering issues around embedded drawings within the document. When the document is scrolled, "old" content stays on the screen, overlapping new content, making it unreadable. I have tried it on Gnome with Wayland and Xorg with the same result. A screen-shot or even better, a test document would be ideal to explain it, but I don't see a way to attach it.

Has anybody seen this kind of behaviour?

Thanks in advance, -Pat

edit retag flag offensive close merge delete

Comments

Well, this issue keeps getting more complicated. Here's a few more things I tried. - Running it in a VirtualBox VM also with Fedora 26, shows the same issue. - Running it in a VNC window, same thing. - Running it with Xfce4 instead of Gnome3, same thing. - Also tried Gnome3, classic, Wayland and XOrg. Same result.

patocarr gravatar imagepatocarr ( 2017-09-06 21:44:20 -0500 )edit

Well, something went awfully wrong with the LibreOffice update. The same document that causes problems with Fedora and the various workarounds tried, causes the same rendering issues under Windows 10, with LO 5.3.4.2. So whatever the issue is, is not Fedora related, but LibreOffice's. There is something put in the document in the last two versions of LO that makes it render badly under any version. Thanks for reading!

patocarr gravatar imagepatocarr ( 2017-09-06 22:53:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-09-07 17:13:03 -0500

patocarr gravatar image

This is a LibreOffice 5.3.6.2 bug, and it may be reproduced as follows:

  • Create blank Writer document.
  • Insert Object/OLE Object/LibreOffice Drawing. Leave it at the default size.
  • Inside the drawing, create some shapes, such as two rectangles.
  • Exit the drawing.
  • Add lots of text underneath it, filling two pages or so, to allow it to scroll more than one page.
  • Scroll up and down and the rendering effect should be shown.

An interesting thing here, saving this document with LO 5.3.6.2 will make it fail on previous versions as well. When I downgraded LO to 5.3.5.1, the effect was also there, but it only took editing the OLE drawing for it to go away for good.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-06 15:51:59 -0500

Seen: 96 times

Last updated: Sep 06 '17