Ask Your Question
0

Samba clients are extremely slow to authorize

asked 2017-09-07 13:40:56 -0600

toddandmargo gravatar image

If your Samba clients are extremely slow to authorize, my notes on the cure to follow:

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-09-07 13:43:10 -0600

toddandmargo gravatar image

updated 2017-09-07 14:03:28 -0600

smbclient is REALLY SLOW! Clients are extremely slow.

smbclient -L 127.0.0.1

is very, very slow. It comes back correctly, but takes 20 seconds.

Add 127.0.0.1 on /etc/hosts, e.g.

# more /etc/hosts

127.0.0.1   server.bozo.local localhost localhost.localdomain localhost4 loca
lhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

Note: 1) common error: you reversed some letters in the host name, e.g "bzoo" instead of "bozo"

2) you will see a strange log file in /var/log/samba called

        /var/log/samba/samba-log.______________________________

   this is due to time outs from clients caused by the above missing entry in /etc/hosts

3) your host name point to ".com" and not ".local"  (to the wrong place essentially)

4) you can reproduce the symptoms on your local machine (takes forever to prompt for the password) with

       $ smbclient -L ServerName -U workcentre -W SambaUserName

   When corrected, the password prompt should be instant. You don't need to enter it for this test
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-07 13:40:56 -0600

Seen: 44 times

Last updated: Sep 07 '17