Ask Your Question
1

need syntax for multiple excludes in /etc/dnf/dnf.conf

asked 2017-09-08 14:32:59 -0500

toddandmargo gravatar image

updated 2017-09-08 14:33:56 -0500

Hi All,

When adding multiple excludes to /etc/dnf/dnf.conf, what is the proper syntax?

[main]
exclude=xrdp
exclude=xorgxrdp

or
exlude=xrdp,xorgxrdp
or
exlude=xrdp xorgxrdp
edit retag flag offensive close merge delete

Comments

I don't think this is a duplicate. The linked Q/A does not tell you the syntax to exclude two packages or a list of packages, which was the question here. It also does not tell you how to exclude packages in Fedora releases that use dnf 2.x.

florian gravatar imageflorian ( 2017-09-11 16:32:22 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2017-09-08 15:43:42 -0500

florian gravatar image

updated 2017-09-11 10:30:39 -0500

For dnf versions < 2.0 like in Fedora 25:

exclude=package1 package2 abc* *xyz

Source: man dnf.conf


For dnf > 2.0 (like in Fedora 26 +):

excludepkgs=package1 package2 abc* *xyz

Source: latest DNF online docs

edit flag offensive delete link more

Comments

excludepkgs or exclude ?

Not seeing "exclude" in "man dnf.conf" and the opposite in "man dnf"

toddandmargo gravatar imagetoddandmargo ( 2017-09-08 16:00:35 -0500 )edit

I edited my answer, options are different for DNF 1.x and 2.x. BTW: In your case a exlude=x*rdp would be sufficient but that's coincidence.

florian gravatar imageflorian ( 2017-09-11 10:34:17 -0500 )edit
0

answered 2017-09-08 14:43:09 -0500

edit flag offensive delete link more

Comments

If I wanted to use a wild card to exclude abcxxx, abcyyy, abczzz packages, would the syntax be

exclude=xrdp xorgrdp abc*
toddandmargo gravatar imagetoddandmargo ( 2017-09-08 15:07:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-08 14:32:59 -0500

Seen: 409 times

Last updated: Sep 11 '17