Ask Your Question
2

Vim.desktop doesn't work corectly. [Solved]

asked 2017-09-19 18:25:23 -0500

Simon98 gravatar image

updated 2017-09-29 07:04:45 -0500

Hi I have a problem to load my vim with a launcher (.desktop file I mean) not by terminal. Actually I created a .desktop file in: /usr/share/applications with these descriptions: Link: https://paste.fedoraproject.org/paste... and I executed vim.desktop with this command: sudo chmod +x vim.desktop Now when I search for vim in gnome, It's appear just like an application but when I click on it, It won't start and won't show anything. I guess there is a wrong with "exec=" option that it can start with it. So please let me know how can I fix this problem

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
4

answered 2017-09-20 06:30:06 -0500

villykruse gravatar image

Try adding the entry

Terminal=true

to the .desktop file.

Here is the documentation

edit flag offensive delete link more

Comments

i tried this way, it starts vim on terminal but I want start vim just like an application(look like other applications) on my dock. Is there anwrong with "exec=" option? or Is there any way to start it like an application? @villykruse

Simon98 gravatar imageSimon98 ( 2017-09-20 10:05:01 -0500 )edit

Then you need to run gvim, and in a comment you said you don't like gvim. You can't run vim without a terminal to run it in.

villykruse gravatar imagevillykruse ( 2017-09-20 10:15:54 -0500 )edit
2

answered 2017-09-19 21:05:09 -0500

jmt gravatar image

updated 2017-09-19 21:06:41 -0500

vim is a terminal application so starting it with a .desktop file makes no sense.

There is a package called vim-X11 which provides gvim which is a version of vim that runs in a window. This package also provides the .desktop file for gvim

edit flag offensive delete link more

Comments

I know that there is a package called vim-X11 in repositories, but it will provide Gvim for me and I don't like to use Gvim. I just want a launcher on my dock that it can launch vim directly when I click on it. I did this action in Kubuntu 17.04 a few month ago and it worked on that but it doesn't work In Fedora Gnome 26. However, is there any way to make it works? @jmt

Simon98 gravatar imageSimon98 ( 2017-09-19 22:39:45 -0500 )edit
1

answered 2017-09-20 10:54:56 -0500

Nicholas gravatar image

You will need to create a vim.desktop file in:

/home/[user]/.local/share/applications

Example vim.desktop file:

[Desktop Entry]
Type=Application
Encoding=UTF-8
Name=VIM
Comment=Vim IMproved
Exec=/usr/bin/vim
Icon=/tmp/vim-300x300.png
Terminal=true

Then reload your gnome-shell:

killall -HUP gnome-shell
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-19 18:25:23 -0500

Seen: 111 times

Last updated: Sep 29 '17