Ask Your Question
1

Fedora 26 Wifi Doesn't Work - Mediatek 7630e

asked 2017-09-20 08:16:49 -0500

jpmarques gravatar image

I just installed fedora 26 but wi-fi isn't working. I can't find it in the network settings.

I have mediatek 7630e card.

Already tried to install https://github.com/neurobin/MT7630E but didn't work. when i execute ./install I get this:

[root@localhost MT7630E]# ./install
make -C /lib/modules/4.11.8-300.fc26.x86_64/build M=/home/joaomarques/.local/share/Trash/files/MT7630E-release/MT7630E/rt2x00 modules
make[1]: *** /lib/modules/4.11.8-300.fc26.x86_64/build: No such file or directory.  Stop.
make: *** [Makefile:9: all] Error 2

I'm new to linux. please help.

thanks

edit retag flag offensive close merge delete

Comments

2

@jpmarques, please install kernel-headers and kernel-devel packages

hhlp gravatar imagehhlp ( 2017-09-20 11:15:35 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-09-20 12:45:17 -0500

Nicholas gravatar image

updated 2017-09-20 13:27:32 -0500

I'm making some assumptions here, and they might not be correct, but If you have UEFI-native mode (BIOS, but not BIOS) then you will want to check if Secure Boot is enabled. Additionally, consider enabling BIOS compatibility mode (CSM) which by default disables Secure Boot. After you've sorted this matter out, follow the installation section, but your family is RedHat using the dnf package manager.

build-essentials (dnf):

sudo dnf install make automake gcc gcc-c++ kernel-devel kernel-headers

This will install more than you need, but here:

sudo dnf grouplist

sudo dnf groupinstall "C Development Tools and Libraries" "Development Tools"

https://github.com/neurobin/MT7630E

Quote (github) link above:

Secure Boot

Not being signed, this driver is not expected to work on secure boot.

Important UEFI reading material:

Fedora Project - UEFI

Wikipedia - UEFI

edit flag offensive delete link more
0

answered 2018-03-19 02:39:58 -0500

kurtyu gravatar image

On top of the answer of @Nicholas, I had to execute the following for my laptop prior to executing sudo ./install.

sudo yum install kernel-devel-4.13.9-300.fc27.x86_64
sudo yum install elfutils-libelf-devel

I'm using Fedora 27, by the way.

Then I had to follow the instructions here (see the answer of Pilot6). The BIOS option did not work for me, so I had to use the mokutil option which worked for my laptop.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-20 08:16:49 -0500

Seen: 403 times

Last updated: Sep 20 '17