English
Ask Your Question
1

Can't play mp4/h264 video on Fedora 26 (firefox)

asked 2017-10-08 14:47:28 +0000

ldeniau gravatar image

Hello,

I spent hours trying to play mp4/h264 video on Fedora 26 but i keep having codec errors on Firefox and GNOME videos.

I followed instructions here https://fedoraproject.org/wiki/OpenH264 . And i've installed libmp4v2 from RPM fusion. But it didn't work.

Then i've desperately installed all gstreamer-plugins... but it still doesn't work.

However, i can play mp4 videos with vlc and chrome but my main goal is to use firefox without problem with video streaming...

If anybody had an idea, it'll be great ! :)

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2017-10-09 14:06:46 +0000

Daniel01 gravatar image

updated 2017-10-09 14:17:59 +0000

You need to add the RPMFusion to your repositories and install the ffmpeg package. I think the article you point out is kind of deprecated, the idea is that Firefox changed some things in regard to how it handles codecs and ffmpeg is compatible with it.

edit flag offensive delete link more

Comments

This test page will tell you which video format is supported.

villykruse ( 2017-10-09 14:40:53 +0000 )edit

It worked. Thank you very much Daniel01. I still trying to understand. I was testing on Lynda.com and http://www.html5videoplayer.net/html5... . I decided to reinstall my Fedora and install only ffmpeg. It work perfectly on my testing sites. But on the Youtube test page linked by villykruse, i've got H.264 and MSE & H.264 failed. Then i've reinstall packages describe here https://fedoraproject.org/wiki/OpenH264 and H.264 and MSE & H.264 is now supported on the Youtube test page... I feel like i'm missing something ^^'

ldeniau ( 2017-10-10 00:34:52 +0000 )edit
0

answered 2017-10-08 18:03:26 +0000

masteroman gravatar image

Have you turned on "Play DRM content" option in Firefox settings?

If not, go to Preferences > Content > Tick on "Play DRM Content"

I remember having issue with that one time..

edit flag offensive delete link more

Comments

It didn't work :/. But it's good to know this parameter :)

ldeniau ( 2017-10-09 23:58:46 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-10-08 14:47:28 +0000

Seen: 319 times

Last updated: Oct 09