English
Ask Your Question
2

How to properly mount other partitions (NTFS) on my Fedora FSH?

asked 2017-10-10 16:08:13 +0000

SomuSysAdmin gravatar image

I recently switched to Fedora 27 Beta (UEFI install, dual-boot with Win 10), and I changed my /etc/fstab to include the two following lines:

UUID=D0E24ECDE24EB78C /media/DownloadsBin  ntfs-3g  auto,user,rw,x-gvfs-show  0 0
UUID=4E565C9C565C869D /media/VMs           ntfs-3g  auto,user,rw,x-gvfs-show  0 0

It should have loaded the devices bearing the given UUIDs into /media/DownloadsBin and /media/VMs appropriately with rw permissions, right? Well, since these are windows partitions, I had to mount them using NTFS-3g. I can see the files, but whenever I even try to create a new folder (e.g. using mkdir test), I get the error:

mkdir: cannot create directory ‘test’: Read-only file system

The strange part is a similar script worked before on Fedora 26, although I'm not sure if it's got something to do with Fedora 27 Beta (a bug?!) or if there's an error in my code. So, I've come to ask the experts for help!

NOTE : I really don't wanna mess around with partition or the folder permissions, especially changing the owner, since windows started complaining and stopped me from writing to the disk the last time I tried this! I'm hoping there's a better way I can share entire partitions between Win 10 and Fedora 27 Beta without pissing either operating system off?!


Upon further investigation, it turns out that the partitions might be mounted as read-only as confirmed by findmnt /media/(dir):

[somu@lappyPrime DownloadsBin]$ findmnt /media/DownloadsBin TARGET SOURCE FSTYPE OPTIONS /media/DownloadsBin /dev/sda5 fuseblk,ro,nosuid,nodev,noexec,relatime,userid=0,groupid=0,allowother,blksize=4096 [somu@lappyPrime DownloadsBin]$ findmnt /media/VMs TARGET SOURCE FSTYPE OPTIONS /media/VMs /dev/sda6 fuseblk,ro,nosuid,nodev,noexec,relatime,userid=0,groupid=0,allowother,blksize=4096

Can anyone tell me what's going on?!

edit retag flag offensive close merge delete

Comments

You might need to do a file system check using the windows system. Also, make sure you don't use windows fastboot.

villykruse ( 2017-10-11 13:38:28 +0000 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2017-10-10 20:05:30 +0000

sideburns gravatar image

Welcome to ask.fedora! I've seen this issue a number of times when mounting a partition from fstab that isn't partitioned with a Linux filesystem. I've always found that adding umask=0000 to the mount options clears it up. (No, I don't know why it worked on Fedora 26 but doesn't work now.) Also, as Fedora 27 is still in beta, you'd probably do better asking questions on the appropriate mailing list, as this site is mostly for fully-released versions. In any event, good luck, and keep us informed.

edit flag offensive delete link more

Comments

Could you help me out a bit and tell me where to add the umask attribute? I'm sorry if it's obvious, but I'm new to this and don't wanna accidentally screw the file system!

SomuSysAdmin ( 2017-10-19 17:37:15 +0000 )edit

Sure! post the line in /etc/fstab and I'll tell you where to add it and what to take out.

sideburns ( 2017-10-19 17:51:06 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-10-10 15:40:46 +0000

Seen: 41 times

Last updated: Oct 10