Ask Your Question

Solved: No more cpu frequency scaling - it actually works [closed]

asked 2017-10-16 11:56:37 +0000

Adamclisi gravatar image

updated 2017-10-17 18:22:32 +0000

I'm using Fedora 26 XFCE spin and since the last two kernel updates the cpu frequency remains fixed at the stock frequency. I've checked (booted) with an older kernel and the frequency is scaled down or up as needed. Why is this happening? Edit: Currently I'm at work and I can't check right now, is it possible that I got an unstable, or under development version of the kernel? I think the latest I got is 4.13.

Edit: CPU Frequency scaling works - xfce4-cpufreq-plugin doesn't show current frequency

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by davidva
close date 2017-10-18 17:44:38.000909


Recently I noticed that lscpu no longer shows current CPU frequency (only nominal, minimal and maximal), check what frequencies is powertop reporting, for me it works well.

ozeszty ( 2017-10-17 14:16:39 +0000 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2017-10-17 11:57:30 +0000

masteroman gravatar image

Do you have multiple options when checking available CPU frequencies?

sudo cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies

Have you also tried checking and changing CPU scaling governor? Available list can be found with:

sudo cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors

Current one in use:

sudo cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
edit flag offensive delete link more

answered 2017-10-17 17:54:41 +0000

Adamclisi gravatar image

Thanks for the answer! After checking the /sys/devices/system/cpu/cpu0/cpufreq/scalingcurfreq I realised that frequency scaling actually is working. What wasn't working properly is the xfce4-cpufreq-plugin which for some reason shows me only one frequency while running under kernel 4.13. But the applet works well with the kernel 4.12. That's why I thought the problem was the kernel... I suppose at some point the applet will be fixed...

edit flag offensive delete link more


You're much welcome. If my answer resolved the issue you can accept it with that check arrow on the left hand side besides my post :-)

masteroman ( 2017-10-17 18:38:11 +0000 )edit

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

1 follower


Asked: 2017-10-16 11:49:38 +0000

Seen: 494 times

Last updated: Oct 17 '17