English
Ask Your Question
0

Firefox Quantum rendering problems

asked 2017-11-12 13:01:51 +0000

manfredlotz gravatar image

Hi there, I'm trying out Fedora 27 and thus Firefox quantum.

FF quantum is really fast but there are quite some pages which gets rendered incorrectly. Missing text.

Simple example is: https://fedoramagazine.org/

It looks like this: https://imagebin.ca/v/3h0DrwkEyN2q

(If this is the wrong place for this, I don't know where to report it to the firefox project. )

Anybody else having this?


Manfred

edit retag flag offensive close merge delete

Comments

bug report to mozilla. or bug report to fedora 27 since it is still beta?

steveebey73742 ( 2017-11-12 15:22:59 +0000 )edit

Thanks, now I found bugzilla.mozilla.org where I opened a bug report.

manfredlotz ( 2017-11-12 16:02:04 +0000 )edit

It is displayed properly here. When you select the text, is it readable? It could simply be that you have some GTK theme active that is displaying text in white color and thus making it hard to read.

masteroman ( 2017-11-14 07:43:50 +0000 )edit

Ok, I use Xfce4. Trying different themes didn't change anything. If I run Cinnamon instead of Xfce4 the same happens.

manfredlotz ( 2017-11-14 18:49:59 +0000 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-11-16 12:44:04 +0000

manfredlotz gravatar image

It seems the problem is solved.

For some reason I deinstalled an Opentype font which also contained some directories of woff and woff2 files. I didn't notice it before.

So, after deleting the font and running sudo fc-cache -fsv things are fine now. Firefox 57 works ok and is much faster then the previous version.

edit flag offensive delete link more

Comments

I was wrong. I was just accidentally happening that it worked. Shortly after the problem was back. However, as I learned here: https://bugzilla.mozilla.org/show_bug... it is a bug in FF which can be worked around like this:

This is probably another example of sandbox-related font issues, like bug 1412090. Assuming this is correct, it should be fixed by the latest Nightly builds; a workaround on older versions (like the 57.0 release) is to set security.sandbox.content.level to 1 (or possibly 2?) in about:config, instead of the default level 3.
manfredlotz ( 2017-11-16 18:25:04 +0000 )edit
0

answered 2017-11-14 15:12:28 +0000

genodeftest gravatar image

Did you enable a dark Gtk+ theme in your desktop environment? If yes, you probably allowed theming the content process in Firefox. In about:config, search for widget.content.allow-gtk-dark-theme and widget.content.gtk-theme-override and reset them to their default values.

edit flag offensive delete link more

Comments

Both are set to false.

manfredlotz ( 2017-11-14 18:51:09 +0000 )edit

I can mark the invisible text and paste it in an editor. So it seems it is a white font with a white background.

manfredlotz ( 2017-11-14 19:04:17 +0000 )edit

Do you have a userContent.css file in your firefox profile?

genodeftest ( 2017-11-14 19:12:56 +0000 )edit

No, I do not have any userContent.css file.

manfredlotz ( 2017-11-14 19:32:51 +0000 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-11-12 13:01:51 +0000

Seen: 663 times

Last updated: Nov 14