Ask Your Question
1

upgrade to Fedora 27 error from Fedora26

asked 2017-11-16 05:23:09 -0500

Nomad gravatar image

I upgraded my system before upgrading to 27 and I run the following command.

sudo dnf system-upgrade download --refresh --releasever=27

but this command gave me this error:

Error: 
 Problem: nss-pem-1.0.3-3.fc26.i686 has inferior architecture
  - nss-pem-1.0.3-3.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package nss-pem-1.0.3-3.fc26.i686

I tried to do this using software center but software center gave me unable to upgrade error message too.

how can I fix this problem and update to my system to 27 ? thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-11-16 05:46:03 -0500

Aleksandar Kostadinov gravatar image

updated 2017-11-16 05:47:22 -0500

First try dnf upgrade. Then you can try to get rid of i386 and i686 packages in your system. Provided nss-pem is the problem, try installing x86_64 nss-pem (and if possible removing the i386 version). Then try downloading again.

Also might be worth reporting bug in bugzilla.redhat.com

Another possible issue might be that the x86_64 version of nss-pem was not yet pushed to the repo while you saw newer version in i386. So perhaps if you just try again later or against different mirrors it would work.

edit flag offensive delete link more

Comments

1

thanks very very much it worked. I updated my system.

Nomad gravatar imageNomad ( 2017-11-16 06:26:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-11-16 05:23:09 -0500

Seen: 728 times

Last updated: Nov 16 '17