Fedora 26 -> 27 Error [closed]

asked 2017-11-17 03:48:17 -0500

MaoTao gravatar image

Hello community,

When i try to upgrade i get this unpleasant error:

Error: 
 Problem 1: package ceph-devel-compat-1:10.2.7-2.fc26.x86_64 requires libcephfs-devel = 1:10.2.7-2.fc26, but none of the providers can be installed
  - libcephfs-devel-1:10.2.7-2.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package ceph-devel-compat-1:10.2.7-2.fc26.x86_64

I have both of mentioned packages above installed in my system. What is the actual problem here?

Just point me to a direction, so i can try to fix it please.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by MaoTao
close date 2017-11-17 15:31:18.784633

Comments

2

Is ceph installed from some third-party repository? Or is it installed from the official one? Basically, it is complaining that ceph-devel-compat requires exact 1:10.2.7-2.fc26.x86_64 version of the program which is not available in distupgrade repository when trying to upgrade.

Perhaps packages aren't upgraded or available in distupgrade repository yet. If you're not using ceph at all, I would say it is safe to remove it then install if needed once again after the upgrade is done.

masteroman gravatar imagemasteroman ( 2017-11-17 04:05:46 -0500 )edit

Indeed, i just removed the package, and all went smooth with the system upgrade. Probably it was installed as a dependecy.

MaoTao gravatar imageMaoTao ( 2017-11-17 15:30:41 -0500 )edit