Ask Your Question
1

How to make Nvidia driver forget an unplugged display?

asked 2017-11-27 06:05:36 -0600

ssr gravatar image

My Nvidia driver at Fedora (now 27) produces many problems with non-existent VGA display. I have a display attached to DVI. Years ago I plugged in for a short time a second VGA monitor, unplugged it forever, but Nvidia card/driver still remembers it. This make many problems when Linux try to use 2-display configuration with 1 display. Dmesg writes: "WARNING: GPU:0: Unable to read EDID for display device VGA-0". How to make it forget this VGA forever?

edit retag flag offensive close merge delete

Comments

Yes it's disabled in nvidia-settings, problem is that card remembers it anyway.

ssr gravatar imagessr ( 2017-11-27 12:29:56 -0600 )edit

This makes Gnome3 in Fedora 27 unstartable, I see only cursor on black screen. KDE, MATE and Cinnamon do work.

ssr gravatar imagessr ( 2017-11-29 09:03:16 -0600 )edit

This is an Nvidia bug—"a known issue with some bioses" according to https://devtalk.nvidia.com/default/to...

ssr gravatar imagessr ( 2019-01-09 10:54:41 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-07-12 11:51:00 -0600

ssr gravatar image
edit flag offensive delete link more

Comments

Gnome developers don't have much to say: https://gitlab.gnome.org/GNOME/gdm/is...

Still have to "cp /root/.config/monitors.xml /var/lib/gdm/.config/" in Fedora 29 to make Gnome work. Fedora Gnome also tend to forget this sometimes and make me fix again. (note, Ubuntu have it fixed ever)

ssr gravatar imagessr ( 2019-01-09 12:02:31 -0600 )edit

Solved Gnome3 startup, but not "WARNING: GPU:0: Unable to read EDID for display device VGA-0" in dmesg during all day and night

ssr gravatar imagessr ( 2019-01-09 12:23:32 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-11-27 06:05:36 -0600

Seen: 204 times

Last updated: Jul 12 '18