English
Ask Your Question
0

I can't update fedore 26 to 27

asked 2017-11-30 23:12:37 +0000

Body gravatar image

updated 2017-12-01 19:02:14 +0000

florian gravatar image
Total                                            99 kB/s | 143 MB     24:36     
Delta RPMs reduced 902.8 MB of updates to 880.0 MB (2.1% saved)
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/doc/glibc/NEWS from install of glibc-2.25-12.fc26.i686 conflicts with file from package glibc-2.25-7.fc26.x86_64
  file /usr/share/man/man1/xmlwf.1.gz from install of expat-2.2.4-1.fc26.i686 conflicts with file from package expat-2.2.1-1.fc26.x86_64
  file /usr/share/libdrm/amdgpu.ids from install of libdrm-2.4.88-1.fc26.i686 conflicts with file from package libdrm-2.4.82-1.fc26.x86_64
  file /usr/share/doc/fontconfig/README from install of fontconfig-2.12.6-4.fc26.i686 conflicts with file from package fontconfig-2.12.1-4.fc26.x86_64
  file /usr/share/fontconfig/conf.avail/30-metric-aliases.conf from install of fontconfig-2.12.6-4.fc26.i686 conflicts with file from package fontconfig-2.12.1-4.fc26.x86_64
  file /usr/share/fontconfig/conf.avail/30-urw-aliases.conf from install of fontconfig-2.12.6-4.fc26.i686 conflicts with file from package fontconfig-2.12.1-4.fc26.x86_64
  file /usr/share/fontconfig/conf.avail/45-latin.conf from install of fontconfig-2.12.6-4.fc26.i686 conflicts with file from package fontconfig-2.12.1-4.fc26.x86_64
  file /usr/share/fontconfig/conf.avail/60-latin.conf from install of fontconfig-2.12.6-4.fc26.i686 conflicts with file from package fontconfig-2.12.1-4.fc26.x86_64
  file /usr/share/fontconfig/conf.avail/65-nonlatin.conf from install of fontconfig-2.12.6-4.fc26.i686 conflicts with file from package fontconfig-2.12.1-4.fc26.x86_64
  file /usr/bin/fc-cache from install of fontconfig-2.12.6-4.fc26.i686 conflicts with file from package fontconfig-2.12.1-4.fc26.x86_64
  file /usr/share/doc/fontconfig/fontconfig-user.html from install of fontconfig-2.12.6-4.fc26.i686 conflicts with file from package fontconfig-2.12.1-4.fc26.x86_64
  file /usr/share/doc/fontconfig/fontconfig-user.txt from install of fontconfig-2.12.6-4.fc26.i686 conflicts with file from package fontconfig-2.12.1-4.fc26.x86_64
  file /usr/share/man/man5/fonts-conf.5.gz from install of fontconfig-2.12.6-4.fc26.i686 conflicts with file from package fontconfig-2.12.1-4.fc26.x86_64
  file /usr/share/doc/libgcrypt/AUTHORS from install of libgcrypt-1.7.9-1.fc26.i686 conflicts with file from package libgcrypt-1.7.8-1.fc26.x86_64
  file /usr/share/doc/libgcrypt/NEWS from install of libgcrypt-1.7.9-1.fc26.i686 conflicts with file from package libgcrypt-1.7.8-1.fc26.x86_64
  file /usr/share/doc/gstreamer1/NEWS from install of gstreamer1-1.12.3-1.fc26.i686 conflicts with file from package gstreamer1-1.12.2-1.fc26.x86_64
  file /usr/share/doc/gstreamer1/README from install of gstreamer1-1.12.3-1.fc26.i686 conflicts with file from package gstreamer1-1.12.2-1.fc26.x86_64
  file /usr/share/doc/gstreamer1/RELEASE from install of gstreamer1-1.12.3-1.fc26.i686 conflicts with file from package gstreamer1-1.12.2-1 ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2017-12-01 03:30:37 +0000

The issue is do to the i686 packages dependencies, you could remove all i686 packages and re install what you need after update if required.

sudo dnf remove *.i686

Then you can proceed with upgrade.

Good Luck.

edit flag offensive delete link more
0

answered 2017-12-01 23:37:01 +0000

Samuel Sieb gravatar image

updated 2017-12-01 23:39:07 +0000

Somehow dnf is trying to install newer versions of 32-bit libraries than the 64-bit ones that are already installed and isn't updating the 64-bit ones which is very strange. Usually it's the other way around. It would be helpful to see the list of packages that dnf is trying to install. Try adding --refresh to the dnf command line and if that still doesn't help, try again tomorrow.

Update: I just noticed the title of this question. This doesn't look like you're upgrading to F27, it looks like just a normal update. What is the dnf command you used?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-11-30 23:12:37 +0000

Seen: 92 times

Last updated: Dec 01 '17