Ask Your Question
0

Set mouse left handed but touchpad right handed

asked 2017-12-02 04:59:22 -0600

merbau gravatar image

Hello dear Fedora users,

I am having a problem and I cannot solve it myself: I have a laptop with several active users. Laptop has a touchpad and an external mouse. All users prefer their touchpad in right-handed configuration, but left-handed users prefer their external mouse as a left-handed (but touchpad as right-handed).

Left-handed mouse can be configured from Settings -> Mouse & Touchpad, by setting primary button as "Right". But this also maps the touchpad to left-handed configuration for this user, which is not desired.

So, my question is: Is there a way to configure my Fedora so, that above preferences can be fulfilled?

Some background and more info below:

My system is a Fedora 26, and its configuration is up to date. Previously I have used xinput to set button mapping separately for different mice (external, touchpad), but Wayland approach clearly does work like I used to do it in Xorg.

I tried to dig a bit deeper, which is described below, but I am not very confident, that I did this in a correct way:

I tried to study Wayland method for doing left-handed button mapping for each device separately, and stumbled into this documentation: (described here), and tried this:

xinput set-int-prop  xwayland-pointer:13 "libinput Left Handed Enabled" 8 1

Above set property appears in mouse configuration, but this configuration has no effect on my system (both pointer devices have the same mapping, either left or right-handed, as configured in Settings).

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-01-10 23:46:18 -0600

whot gravatar image

GNOME stores the settings in gsettings, but they're not all exposed in the GUI. Let's look at the left-handed key, which you can find after a bit of searching around in the gsettings list-schemas and gsettings list-keys outputs.

$ gsettings get org.gnome.desktop.peripherals.touchpad left-handed       
'mouse'

Let's look at the allowed values for this setting:

$ gsettings range org.gnome.desktop.peripherals.touchpad left-handed
enum
'right'
'left'
'mouse'

From that we guess that mouse ties the touchpad to the mouse setting. So let's disable left-handed mode on the touchpad explicitly:

gsettings set org.gnome.desktop.peripherals.touchpad left-handed 'right'

And that should do the trick.

If xinput only sees an xwayland pointer then your main session runs under wayland, in which case the xorg libinput driver isn't active, so changing the properties has no effect. You need to use the compositor-specific methods to change any settings on input devices instead, in this case gsettings.

and, please don't assume you know what "all users prefer".

edit flag offensive delete link more

Comments

I think with "all users" they only meant all the users on this particular laptop.

Period22 gravatar imagePeriod22 ( 2018-01-11 00:10:12 -0600 )edit

I have tried the changes you have suggested using gsettings under Fedora 29 and for some reason it does not change the configuration on my touchpad. It will still follow the configuration of my mouse. Is there a piece of the puzzle I am missing?

[user@localhost ~]$ gsettings get org.gnome.desktop.peripherals.touchpad left-handed 'right' [user@localhost ~]$ gsettings get org.gnome.desktop.peripherals.mouse left-handed true

bblasco gravatar imagebblasco ( 2018-12-04 21:34:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-02 04:59:22 -0600

Seen: 106 times

Last updated: Jan 10