English
Ask Your Question
1

Internet is getting very slow on Fedora 27

asked 2017-12-03 08:36:27 +0000

ar124official gravatar image

H! I am getting a problem that I use internet through modem. Previously I used it on Windows and it was giving a handsome 500kbps speed. Now I uninstalled the Windows and got Fedora 27. But It is not giving such a speed. It is very slow speed giving of 50kbps-. I checked everything in network setting from Network Icon on windows bar, top of the screen as well as I configured the network through PTCL IP. But all is vain... Please help me troubleshooting this and getting back to my smart download speed.

**ZTE VDSL2 MODEM ROUTER; BROADBAND; CONNECTION TYPE: WIRED


edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2017-12-08 15:22:45 +0000

Neatu Ovidiu gravatar image

One of the problems is that gnome software automatically starts downloading updates at startup. This slows my computer and the internet speed for a time after startup.

You could disable it: https://ask.fedoraproject.org/en/ques...

Just issue in terminal "sudo dnf update" whenever you want to bring Fedora up to date.

edit flag offensive delete link more
0

answered 2017-12-05 22:40:55 +0000

sideburns gravatar image

Welcome to ask.fedora! This may or may not be a fedora issue, so let's do a bit of testing to find out. First, open a terminal and run this command:

ping -c 10 mit.edu

When it's done, check to see if there was any packet loss, and what the average time was. Next,

ping -c 10 jpl.nasa.gov

and again, check the statistics. This will give you two sets of data from locations on opposite sides of North America, and probably across different parts of the backbone. For me, in Southern California, the average time for mit.edu was 38.696ms, just to give you an idea. Unreasonably long times, or significant packet loss indicates a network issue, that you need to take up with your ISP. If all seems well, we can look further at your computer's config and see what needs tweaking.

edit flag offensive delete link more
0

answered 2017-12-05 00:44:24 +0000

christianbueno gravatar image

updated 2017-12-06 19:36:58 +0000

You could disable ipv6 in "Wired connected>wired settings", if you still have problems , directly in firefox you could disable ipv6.

  • In the search bar type : about:config
  • search: network.dns.disableIPv6 and change the value to True

I do not know how disable that in chrome, sorry
If you have problems about failed sync when you install programs or update the system by the terminal, or it is very slow in the beginning , you could use the -4 option always to force ipv4, for example:


sudo dnf update -4
or 
sudo dnf install screenfetch -4

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Use your votes!

  • Use the 30 daily voting points that you get!
  • Up-vote well framed questions that provide enough information to enable people provide answers.
  • Thank your helpers by up-voting their comments and answers. If a question you asked has been answered, accept the best answer by clicking on the checkbox on the left side of the answer.
  • Down-voting might cost you karma, but you should consider doing so for incorrect or clearly detrimental questions and answers.

Question Tools

Follow
1 follower

Stats

Asked: 2017-12-03 08:36:27 +0000

Seen: 169 times

Last updated: Dec 08