Lightdm doesn't show anymore since I install Nvidia driver. What command I need to do to solve this please?

asked 2017-12-06 18:59:33 +0000

Fedora 27 Gnome, Mate, Cinnamon Memory 32 GB Processor AMD Ryzen 7 1700x Graphics Nvidia Geforce GTX 1060 Os type 64 bits disk ssd 240gb

the only way I enter my session is with the command startx :(

[ 140.581] X.Org X Server 1.19.5 Release Date: 2017-10-12 [ 140.582] X Protocol Version 11, Revision 0 [ 140.582] Build Operating System: 4.12.9-300.fc26.x8664 [ 140.582] Current Operating System: Linux localhost.localdomain 4.13.16-300.fc27.x8664 #1 SMP Mon Nov 27 18:19:43 UTC 2017 x8664 [ 140.583] Kernel command line: BOOT IMAGE=/vmlinuz-4.13.16-300.fc27.x86_64 root=UUID=f499af8c-f63e-4194-9b9a-b9ff6221f4f5 ro rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rhgb quiet rd.driver.blacklist=nouveau [ 140.584] Build Date: 12 October 2017 07:35:27PM [ 140.584] Build ID: xorg-x11-server 1.19.5-1.fc27 [ 140.584] Current version of pixman: 0.34.0 [ 140.585] Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. [ 140.585] Markers: (--) probed, ( ) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. [ 140.586] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Dec 3 22:34:41 2017 [ 140.588] (==) Using config directory: "/etc/X11/xorg.conf.d" [ 140.588] (==) Using system config directory "/usr/share/X11/xorg.conf.d" [ 140.589] (==) No Layout section. Using the first Screen section. [ 140.589] (==) No screen section available. Using defaults. [ 140.589] () |-->Screen "Default Screen Section" (0) [ 140.589] (**) | |-->Monitor "<default monitor="">" [ 140.590] (==) No monitor specified for screen "Default Screen Section". Using a default monitor configuration. [ 140.590] (==) Automatically adding devices [ 140.590] (==) Automatically enabling devices [ 140.590] (==) Automatically adding GPU devices [ 140.590] (==) Automatically binding GPU devices [ 140.591] (==) Max clients allowed: 256, resource mask: 0x1fffff [ 140.591] (==) FontPath set to: catalogue:/etc/X11/fontpath.d, built-ins [ 140.591] (==) ModulePath set to "/usr/lib64/xorg/modules" [ 140.591] (II) The server relies on udev to provide the list of input devices. If no devices become available, reconfigure udev or disable AutoAddDevices. [ 140.591] (II) Loader magic: 0x821e00 [ 140.591] (II) Module ABI versions: [ 140.591] X.Org ANSI C Emulation: 0.4 [ 140.591] X.Org Video Driver: 23.0 [ 140.591] X.Org XInput driver : 24.1 [ 140.591] X.Org Server Extension : 10.0 [ 140.592] (++) using VT number 1

[ 140.597] (II) systemd-logind: took control of session /org/freedesktop/login1/session/31 [ 140.599] (--) PCI:*(0:36:0:0) 10de:1c03:1462:3283 rev 161, Mem @ 0xfc000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072 [ 140.599] (II) LoadModule: "glx" [ 140.599] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so [ 140.608] (II) Module glx: vendor="X.Org Foundation" [ 140.608] compiled for 1.19.5, module version = 1.0.0 [ 140.608] ABI class: X.Org Server Extension, version 10.0 [ 140.726] (==) Matched nouveau as ... (more)

edit retag flag offensive close merge delete

Comments

Welcome to ask.fedora. First, are you sure that you're using lightdm, instead of gdm, which is Gnome's default? Let's kill two birds with one stone, by running this in a terminal: systemctl status lightdm.service and letting us know if it's active, dead, or simply not found.

sideburns ( 2017-12-07 03:56:44 +0000 )edit

systemctl status lightdm.service ● lightdm.service - Light Display Manager Loaded: loaded (/usr/lib/systemd/system/lightdm.service; disabled; vendor pre Active: inactive (dead) Docs: man:lightdm(1)

Gaijin6 ( 2017-12-08 22:16:50 +0000 )edit

systemctl status gdm.service ● gdm.service - GNOME Display Manager Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: Active: inactive (dead)

Gaijin6 ( 2017-12-08 22:19:06 +0000 )edit

I'm not surprised that lightdm is dead, as you can't have two Display Managers running. Try masking gdm, rebooting and see what happens.

sideburns ( 2017-12-08 23:19:21 +0000 )edit

Masking how what command please? I just need Lightdm I don't need GDM.

Gaijin6 ( 2017-12-09 02:37:58 +0000 )edit