Ask Your Question
2

Fedora 27 Workstation GDM causing problems

asked 2017-12-13 01:58:50 -0500

samcompton gravatar image

updated 2017-12-13 06:33:24 -0500

Can anyone enlighten me on this problem.

Computer:

Desktop Intel Core i5 3rd generation Nvidia GTX 660 Nvidia Driver 387 installed

So, I had Fedora Workstation 26 on my computer and it worked really well. I upgraded to Fedora Workstation 27 and encountered a lot of problems such as system freezing and programs not displaying properly. I have reinstalled fresh multiple times and still encounter the same problems. The interesting thing is today I tried again. In the midst of trying to get Gnome Video player to display properly I inadvertently uninstalled the Gnome Desktop. So I logged into the terminal and reinstalled Gnome Desktop. Upon rebooting I discovered GDM was not enabled. I just used startx to get into the Gnome Desktop and everything works perfectly. In the past I have logged into Gnome X11 from GDM and still experienced problems. Only starting X from TTY session works properly. Just to make sure I re-enabled GDM and all of the problems returned. I tried installing and enabling lightdm but, it just hangs on boot. So I am very happy with how my system is running but, would like to have a display manager to login.

Has anyone experienced these issues? Can anyone suggest a display manager alternative?

Thank you.

Edit: Lightdm hang was my fault. I had only installed lightdm and not the gtk-greeter. Lightdm is now functioning properly. I did talk with someone on reddit r/fedora that experienced the same issues with an Nvidia GTX 690 card. It seems there is some issue with that series of graphics card and the new setup in Fedora 27 Gnome gdm.

edit retag flag offensive close merge delete

Comments

GDM by default runs on wayland. Check GDM docs for running it on Xorg.

fcomida gravatar imagefcomida ( 2017-12-13 03:39:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-12-14 14:13:44 -0500

ssieb gravatar image

It sounds like Wayland doesn't work well with your NVidia video device. Probably because you're using the proprietary driver.

When you click on your name at login and before you enter your password, there is a little gear icon. Click on that and select the Gnome on Xorgsession option. The other way is to edit /etc/gdm/custom.conf and uncomment the WaylandEnable=false line to completely disable Wayland.

edit flag offensive delete link more

Comments

I have similar problem with fedora 27 workstation(gnome desktop), or specifically with GDM. https://ask.fedoraproject.org/en/ques...

christianbueno gravatar imagechristianbueno ( 2018-03-24 14:48:11 -0500 )edit

On fedora 27 kde plasma spin , I don't have problems.

christianbueno gravatar imagechristianbueno ( 2018-03-24 14:49:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-13 01:58:50 -0500

Seen: 2,315 times

Last updated: Dec 14 '17