Ask Your Question
0

virt-viewer not as root?

asked 2017-12-18 19:03:12 -0500

toddandmargo gravatar image

Hi All,

I could not take Scientific Linux 7.4 (RHEL clone based on CentOS) anymore. It is just too gash darned buggy and so terribly out-of-date that it drove me insane. And nothing gets fixed as it is too out-of-date to get fixed. Anyway I wiped and re-installed Fedora Core 27. Oh my goodness what a change to have everything working well! And stable finally too! (RHEL is NOT more stable.)

Anyway, I use to communicate with my virtual machines (VM's) as a user with qemu-kvm as follows:

$ remote-viewer spice://127.0.0.1:5900 --title "KVM-W7"

Now I must be root to view my VM's:

$ beesu "/usr/bin/virt-viewer KVM-W7"

Is there a way to do this without being "root" like I use to?

Many thanks, -T

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-12-18 23:57:30 -0500

toddandmargo gravatar image

Figured it out.

In virt mamager, you select a unique port for Spice and then simply run

$ remote-viewer spice://127.0.0.1:5903

I was trying to select a TLS port too, which tripped me up.

edit flag offensive delete link more
1

answered 2017-12-19 13:34:13 -0500

sdyroff gravatar image

You can also try

virt-viewer --connect qemu:///system

as non root user

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-12-18 19:03:12 -0500

Seen: 71 times

Last updated: Dec 19 '17